Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


20 Marzo 2019 Postato da: Boss
Amithlon su VM
ultimamente stò sperimentando amithlon su Virtualbox seguendo delle guide e leggendo delle discussioni su EAB dell'utente "SnkBitten" vedi anche le sue pagine:

guida aggiornata al 2016
amithlonblog

ho aggiornato la mia iso di Amithlon per poter girare su sitemi recenti (x86 e x64) anche con molta ram (amithlon vedrà comunque 1GB) e grafica vesa di default.

su virtualbox al momento sono riuscito a configurare l'audio, usb e video..

->Continua<-

Commenti: 146  Aggiungi - Pagine: 1...-4-5-6-7-8


Pagine: -1-2- [3] -4-5-6-7-8-

Post inviati: 188

Visulizza profilo Messaggio Personale
204.108.79.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36
Commento 41 in risposta al 35 di amiwell79
saimon69 15 Ottobre 2019    01:13:19
Citazione

Amiga Inc. approvò il progetto di Ber Mayer ed era abbastanza entusiasta, ma dalla comunità ci fu il nulla e tutt'ora è così, non ci sono neanche gli strumenti di sviluppo adeguati nativi.



La cultura degli "intel outside", che da una parte ha affossato Amithlon e dall'altra ha rallentato enormemente AROS fino a tempi recenti secondo me...

... e prima di andare avanti vorrei ricordare che ero uno di loro, almeno in parte: penbsare di avere Amiga OS su un processore non-68000 e (nella mia mente) coi colori squillanti pacchiani di una VGA pareva un abominio!

Diversi anni di uso del PC e Mac per lavoro, oltre a vedere e testare build funzionanti di AROS mi han fatto cambiare idea, pero'...

Commento modificato il 15/10/2019 alle ore 01:13:38


-------------------------------------------------- --------

http://scarabocchibinari.ilcannocchiale.it - mio blog online

http://binarydoodles.wordpress.com - blog in inglese

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 42
amiwell79 15 Ottobre 2019    10:57:32
mah io ero un ragazzino, cmq mi accorsi quando commodore non c'èra piu' e non avevo neanche una mia amata rivista che compravo con entusiasmo(avevano chiuso tutte bottega)

Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
82.49.224.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.2.14
Commento 43 in risposta al 40 di VagaPPC
Boss 15 Ottobre 2019    18:37:33
Citazione

Il problema è lo stesso che incontrai con QEMU.
Ovvero l'emulazione del chip video tseng, quello della picasso per intenderci.
È soltanto un emulazione parziale.
Dovrei provare con l'ultima versione di QEMU, tra l'altro il team sta lavorando per l'emulazione della ATI Radeon 9200.
Quando sarà pronto, si può riprovare


amithlon come progetto non è mai stato terminato, quidi qualche bug su pc moderni e macchine virtuali non devono stupire. stiamo parlando anche di un kernel che se pur aggiornato poggia su delle basi del 2002 (le distro linux di quei tempi faceno abbastanza pena al confronto di quelle attuali).
apparte gli Amithlon update, nessuno ha cerca di risolvere qualcosa nell'eseguibile loadlin che lancia una vera e propria emulazione della vmlinux. amithlon è molto intrecciato tra hardware, linux e amiga os, spesso ha comportamenti strani per questo motivo. poi c'è anche da considerare che non era pensato per essere usato in questo modo, non doveva fare il boot da hard disk e sopratutto con i pc di oggi... secondo me doveva servire per una fase transitoria dall'hardware amiga al x86, di certo non doveva fermasi li il progetto.

A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 44
amiwell79 15 Ottobre 2019    19:53:53
io ho visto girare xine su amithlon, non so come mai Bern non lo abbia incluso nel pacchetto cmq forse il problema era che non supportava i chip custom e poi si non ha attirato l'attenzione dovuta.

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 45
amiwell79 16 Ottobre 2019    10:41:48
c'è stata un'evoluzione di amithlon ma mai rilasciata si chiamava umilator, cmq sto lavorando con amigasys live installato su hd, penso si possa fare il dual boot con qualsiasi sistema perchè installa grub, ma avvio puppy da chiavetta quando ho bisogno

Pegasus RyuSei Ken

Post inviati: 9316

Visulizza profilo Messaggio Personale
79.31.126.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36
Commento 46
Seiya 16 Ottobre 2019    10:58:46
tu li hai provati un po' tutti e ogni tanto ci riprovi con questi AmigaOS like e quindi ora hai trovato quello definitivo, quello che pensi: "ok, questo è il migliore, uso questo".

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 47
amiwell79 16 Ottobre 2019    11:06:39
penso che il migliore è amithlon, non ci sono discussioni, dovrei prendere di nuovo una scheda grafica supportata e la sblive, ma sto aspettando la pecunia, volevo visto che amigasys emula la porta parallela prendere un digitalizzatore, ma penso che non è la strada giusta, vedremo

Pegasus RyuSei Ken

Post inviati: 9316

Visulizza profilo Messaggio Personale
79.31.126.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36
Commento 48
Seiya 16 Ottobre 2019    11:09:28
AmigaSys live non monta i CD-ROM perchè lato AmigaOS non si interfaccia bene con il sistema di montaggio linux quindi da quel punto di vista avresti problemi se trovi dei CD compilation o software che vuoi usare.

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 49
amiwell79 16 Ottobre 2019    11:17:13
si difatti ho riscontrato questo problema, cmq ho visto che i digitalizzatori li vendono a prezzo di una scheda video e sblive che mi serve quindi opterrò per la strada amithlon, ho un processore xeon mi sembra x5560 a 3 Ghz e ram ddr3.

Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
87.19.247.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.2.14
Commento 50
Boss 16 Ottobre 2019    18:20:39
se non ricordo male, amigasys non è altro che slax, cioè una mini distro linux con tanto di interfaccia grafica (stile puppy linux) con qualche comando da tastiera si riesce ad uscire dall'emulatore, vedere ed usare linux per modificare il file di configurazione che utilizza "amigasys". l'ho provato tempo fa, ero riuscito facilmente ad installarlo su HD su cui faceva il boot. in pratica installi linux (una distro leggera qualunque) e installi fs-uae che si avvia sopra linux quando accendi il pc. quindi in poche parole non hai neanche bisogno di installare linux per avere le comodità, avvi amigasys poi chiudi l'emulatore, installi i pacchetti necessari ad usare firefox (o quello che più ti aggrada) e usi il browser sui siti meno amigosi

A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** IBrowse/2.5demo (Amiga; AmigaOS 3.1; Build 25.86 68K)
Commento 51
amiwell79 16 Ottobre 2019    20:19:58
dovrei collegarmi al sito ufficiale per capirci qualcosa, cmq posso accedere a linux facilmente (chiudendo e-uae), ma è una versione preistorica direi quindi penso che si dovrebbè smanettare direi non poco e non so se si riuscirebbe a cavarne un ragno dal buco, ho visto chè l'architettura è a moduli, menomale che c'è quello per la mia nvidia così ho una risoluzione 1680x1050.
Cmq ho preso quello che mi serve per amithlon, poi in extremis utilizzerò puppy che tra laltro mi da delle rogne, parlo della versione a 64 bit, la cpu schizza a pieno carico e tutto si rallenta, non mi succedeva con la versione a 32 bit

Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
79.37.243.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3
Commento 52
Boss 23 Novembre 2019    10:46:35
qualche giorno fà ho comprato un Atomic Pi , ho voluto provare windows 10 come si comportava, e tutto sommato l'esperienza non è stata male (i 2Gb di ram sono veramente stretti). così mi è venuta l'idea di provare Amithlon con afaOS su virtualbox, con mio stupore funziona tutto perfettamente (video, audio, ecc). ho notato solo la freccia del mouse che lagga un pochino (potrebbe essere colpa del mio HUB usb cinese). a questo punto confermo la teoria che con windows 10 (bios uefi quindi), ci sono buone probabilità chè l'emulazione di Amithlon funzioni correttamente, invece con un bios uefi in modalità di compatibilità (es con windows 7) non si ottene un sistema funzionante al 100% (crash dei video e lan non funzionante).

Commento modificato il 23/11/2019 alle ore 10:51:08


A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0)
Commento 53
amiwell79 28 Novembre 2019    08:00:39
ho due schede grafiche ben supportate non so se in vesa, ho provato una radeon x7xx (in passato una x1150) ed una nvidia 8400gs quella che attualmente uso con aros

Commento modificato il 28/11/2019 alle ore 18:24:03


Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
79.43.243.*** Mozilla/5.0 (Linux; Android 6.0.1; SM-A500FU) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Mobile Safari/537.36
Commento 54
Boss 28 Novembre 2019    13:15:38
@amiwell79 Nel fine settimana proverò una nuova configurazione hardware, una scheda madre p5k con una hd5850 e kernel4 vediamo un po' con un core 2 duo occato a 3ghz come si comporta il tutto. Non sono sicuro che il video sia supportato, nel caso mi sono buildato un nuovo kernel su ubuntu 5.10, che ho nominato kernel5 con tanto di driver.

Commento modificato il 28/11/2019 alle ore 13:16:18


A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0)
Commento 55
amiwell79 28 Novembre 2019    14:48:15
sei un grande un nuovo kernel ma come hai fatto hihi, io nella mia workstation ho problemi con le porte usb (ma senza installare poseidon) quindi all'avvio le mie periferiche usb non vengono rilevate, amithlon supporta un core ma la tua configurazione dovrebbe andare benone, poi dove lo carichi il kernel5, per averne una copia?

Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
87.19.245.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3
Commento 56
Boss 28 Novembre 2019    18:34:10
grazie per i complimenti, ma in realtà non mi sono inventato niente di sana pianta. SnkBitten ha stilato una guida su come compilare il kernel di Amitlon su centOS e Ubuntu 5.10 (non superiore perchè altrimenti, da quel che sò il compilatore gcc non è compatibile). partendo dal kernel 4 dell'utente "milanca" da cui servirà solo il file .config per non perdere i settaggi scelti in precedenza (appunto nel kernel4). basta avere voglia, 2 orette per crearsi una vm con uno dei due os citati sopra, e seguire la guida alla lettera... niente di più. se ti può interessare ti condivido i file (kernel + power_pci driver) ma ti avviso su vm amithlon non riconosce i driver e si avvia correttamente, altre prove non ho fatto, probabilmente i driver andranno configurati adeguatamente sulla macchina ospite dal file di configurazione pci nel cassetto "S:" di Amiga os

Commento modificato il 28/11/2019 alle ore 18:34:51


A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.6.1
Commento 57
amiwell79 28 Novembre 2019    18:56:22
non sapevo ci fosse una guida per compilare un kernel ad hoc, se vuoi linkarmelo faccio una prova, i driver di solito vanno installati con amithlonupdate

Boss

Post inviati: 694

Visulizza profilo Messaggio Personale
37.160.49.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3
Commento 58 in risposta al 57 di amiwell79
Boss 28 Novembre 2019    19:50:20
Citazione

non sapevo ci fosse una guida per compilare un kernel ad hoc, se vuoi linkarmelo faccio una prova, i driver di solito vanno installati con amithlonupdate


hai un MP

A1200/030, APOLLO 1230LC 8MB KICK 3.1 HDD IDE 40GB df1 esterno RECAPPATA 100% || A1200 8MB FAST CF 4 GB RECAPPATA 100% || A500+ CON A501 switch df0 df1 nascosto e gotek esterno (RIPARATE DA ACIDO)

A1200 Raspberry Pi 3B+ con floppy Mod || A500 x64 i5 8GB RAM (Toshiba portege r830)(windows 7) || A2000 X64 Socket 775 XEON E5450 771 MOD 4GB RAM TRIPLE BOOT (WINUAE A4000 AFAOS / WIN7 / UBUNTU)

Commodore 8296 con tastiera, drive 8250lp e stampate ad aghi tutto funzionante

Invalido Civile

Post inviati: 6922

Visulizza profilo Messaggio Personale
46.141.119.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 59
amiwell79 30 Novembre 2019    12:37:45
scusami boss nella guida di skibitten si parla di ahi nativo, sai qualcosa in merito, quello che ho capito io e che aumenta di poco le prestazioni del sistema, forse ci dovrebbe essere un software nativon x86 per non fare carico sempre della cpu, questo riguarda anche per i video, cmq devo indagare su hd-rec nativo, ci sono dei video su internet dove fanno vedere delle cose strabillianti, e si per i video ci vorrebbe mplayer per esempio nativo e risolto tutto, vabè rimane sempre la questione browser

Post inviati: 1119

Visulizza profilo Messaggio Personale
87.7.249.*** Mozilla/5.0 (Windows NT 6.1; rv:70.0) Gecko/20100101 Firefox/70.0
Commento 60
AfAOne 30 Novembre 2019    13:01:25
AHI diventa nativo se ha i driver della Scheda Audio in uso !

Commento modificato il 30/11/2019 alle ore 13:05:38


- AfA One - AROS One x86
- AROS One 68K - AfA One PPC -

- Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1 -

Immagine


Pagine: -1-2- [3] -4-5-6-7-8-

Utenti Online
Utenti registrati: 1000 dal 1 Gennaio 2006
di cui online: 7 registrati - kaffeine - MX3 - sampedenawa - MassimoC - AfAOne - gommaeacca - Fogg_80 -
9 non registrati

Benvenuto all'ultimo utente registrato: 46337

Buon Compleanno a marcos10 - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.083064079284668 secondi