Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


11 Marzo 2019 Postato da: amiwell79
riva piu' veloce di ffplay
ciao

ho convertito un video a 480 di risoluzione in mpeg1, il formato è 850x480 ed ho constatato che con ffplay nel mio sistema è un chiodo, con riva tutto ok anche se leggè da chiavetta, sono soddisfatto

ps. non ho un sistema amithlon molto performante è un bidone hihi, un vecchio pentium 4 a 1.7 Ghz su socket 478
Commenti: 67  Aggiungi - Pagine: 1-2-3-4


Pagine: -1-2- [3] -4-

Post inviati: 1324

Visulizza profilo Messaggio Personale
5.90.9.*** Mozilla/5.0 (Linux; Android 9; G8341) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Mobile Safari/537.36
Commento 41
aleghid 13 Marzo 2019    20:57:04
Beh certamente se utilizzi la chipram sarà quella il collo di bottiglia per vamp. Ma tanto è come parlare col muro.

Non ho capito una cosa: ogni tipo di processore 68k aggiunge o meno registri e istruzioni.
È ovvio che chi ha 020 vuole sfruttarlo, chi ha 030 vuole sfruttare le istruzioni aggiuntive che offre, eccetera eccetera fino allo 060. Tuttu hanno librerie dedicate per sfruttarli.

Bene, alla luce di questo chi ha vampire vuole sfruttare tutte le istruzioni degli altri processori e in più anche ammx se possibile.

È un po come se chi ha 060 venisse demonizzato perchè sfrutta il proprio processore, le proprie libs e le altre feature che quella creaturina è capace di richiamare.

Sapete qual'è il priblema? Che vi dovete accontentare di UAE che ancora non può emulare vampire. Visto che è gratis divresti cercare di smetterla di lamentarti e prendere quello che offre senza fiatare, anzi ringraziando chi lo sviluppa.

Se hai così bisogno di vampire allora ti consiglio di acquistarla, altrimenti piantala di dire boiate grazie Seiya.

Commento modificato il 13/03/2019 alle ore 20:59:24


Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
79.30.56.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36
Commento 42 in risposta al 40 di cgugl
Seiya 13 Marzo 2019    21:19:37
Citazione

Fammi capire cosa vuoi dimostrare:
1) che il processore x86 in emulazione 68K è più veloce del 68030 ?
2) che mpeg123, scritto in C per linux, è più veloce di un programma nativo come RIVA scritto in assembler 68K ?
3) che costringere l'amiga a fare il rendering nella chip memory rende la riproduzione del video lentissima?
4) che riva, pur essendo veloce su 68K, è scritto male perchè su PC non trae benefici dal JIT ?


niente di tutto questo. E' un modo per conoscere meglio l'Amiga e anche per sapere da dove tutto è iniziato. Ma anche per vedere quanto incide la sola potenza bruta di un codice scritto in C e multi piattaforma.
mpeg123 è talmente vecchio che è compilato per 68020 e usi la stessa versione su ogn processre 680x0.

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 43 in risposta al 41 di aleghid
cgugl 13 Marzo 2019    21:22:33
Citazione

Beh certamente se utilizzi la chipram sarà quella il collo di bottiglia per vamp. Ma tanto è come parlare col muro.

Non ho capito una cosa: ogni tipo di processore 68k aggiunge o meno registri e istruzioni.


Non sono programmatore, ma ho sentito dire un sacco di volte che:
Il 68000 è 16 / 32 bit, cioè accede alla memoria a 16 bit ma internamente lavora a 32 bit grazie a 8+8 registri che sono tutti a 32 bit (rispetto agli 8 del x86).

Il 68020 è 32 /32 bit. Ha una piccola cache istruzioni. Ha molte più istruzioni rispetto al 68000 e soprattutto ha modalità di indirizzamento indirette che sono necessarie per la manipolazione dati (hai mai visto decoder mpg, mp3 o jpg sul 68000 liscio? Ti risulta che AHI permetta il play di stream dati?).

Il 68040 ha cache istruzioni e dati da 4k l'una. Ha meno istruzioni del 68020 per motivi di ottimizzazione interna (le istruzioni lente vengono eseguite via software). Ha una struttura a pipeline che permette l'esecuzione parallela di alcune istruzioni... poi fpu integrata, mmu...

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 44 in risposta al 42 di Seiya
cgugl 13 Marzo 2019    21:38:55
Citazione

niente di tutto questo. E' un modo per conoscere meglio l'Amiga e anche per sapere da dove tutto è iniziato. Ma anche per vedere quanto incide la sola potenza bruta di un codice scritto in C e multi piattaforma.
mpeg123 è talmente vecchio che è compilato per 68020 e usi la stessa versione su ogn processre 680x0.


Il fatto che un programma sia scritto per 68020 non è necessariamente sintomo di lentezza.

Anzi, su winuae è consigliato l'uso del 68020 perchè è il processore più completo come set di istruzioni. I processori successivi introducono pipeline (esecuzione parallela), previsioni (unità di previsione) e le cache che a causa del JIT creerebbero solo problemi e nessun beneficio.

Come prestazioni, dal mio punto di vista la gestione è trasparente all'utente.
Cioè, se hai un 68020 sei costretto ad usare un eseguibile 68020 solo perchè il programma compilato per 68040 potrebbe fare uso di una istruzione FPU e vai in guru.
Se hai un 68040 puoi usare l'eseguibile 68020, la cpu farà comunque uso della cache più grande, della pipeline e delle unità di previsione.

Che vantaggi si hanno a compilare per 68040 avendo a disposizione un 68040 ?
Si dice al compilatore sfrutta tutti i 4kb +4kb di cache, evita di usare quelle istruzioni che sono emulate sul 68040 e potrebbero risultare lente.

Commento modificato il 13/03/2019 alle ore 22:13:57

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 45
cgugl 13 Marzo 2019    22:40:22
Ora le faccio io un paio di domande:

- perchè all'università si studia il processore motorola 68K e non l'X86 ?
- perchè sulle macchine 68K si programma in assembler, mentre sui PC non si programma e non si è mai programmato in assembler?


Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
79.30.56.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36
Commento 46
Seiya 13 Marzo 2019    23:19:56
è così faticoso aprire una shell e provare questi due programmi con un qualsiasi mpeg? io questi test li ho fatti su macchine reali. non ha senso farli su un emulatore. E' ovvio che girano molto meglio. Lo scopo non è quello. Te l'ho già detto.

@Amiwell
provali anche tu. io ho anche l'originale Riva, ben diverso da quello attuale.

Post inviati: 1324

Visulizza profilo Messaggio Personale
5.90.5.*** Mozilla/5.0 (Linux; Android 9; G8341) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Mobile Safari/537.36
Commento 47
aleghid 13 Marzo 2019    23:39:21
Se vuoi che provo fammi un pacchetto zip con tutto il necessario, lo faccio per fare un favore a te, quindi preparami almeno il tutto.

Molto appropriato, combatti come un contadino.

E comunque se tu hai fatto i test in ham8 i risultati sono falsati con ham6.

Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
79.30.56.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36
Commento 48
Seiya 13 Marzo 2019    23:51:30
infatti. lascia perdere. Semmai ora io mi provo qualche test e poi semmai faccio uno zippone

Post inviati: 1324

Visulizza profilo Messaggio Personale
5.90.5.*** Mozilla/5.0 (Linux; Android 9; G8341) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Mobile Safari/537.36
Commento 49
aleghid 13 Marzo 2019    23:56:07
Se fai test su UAE sono inutili. Falli su hardware reale.

Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
79.30.56.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36
Commento 50
Seiya 14 Marzo 2019    00:19:41
io i test li faccio senza il jit ne ho già beccati alcuni che sono più lenti di un 68060. Ma li faccio solo per provare come funzionano i test. li ho già fatti anni fa con l'hardware reale.

Post inviati: 1324

Visulizza profilo Messaggio Personale
5.90.5.*** Mozilla/5.0 (Linux; Android 9; G8341) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Mobile Safari/537.36
Commento 51
aleghid 14 Marzo 2019    00:55:25
Sai benissimo che anche senza jit i test con UAE sono da prendere con le pinze visto che non puoi decidere la velocità in Mhz del processore che scegli.

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 52 in risposta al 27 di Seiya
cgugl 14 Marzo 2019    09:22:01
Citazione

come fare i test:

Amipeg:
mpeg_play (si apre un requester, scegli NTSC 640x400 interlacciato e poi il file da vedere. Alla fine ti mostra i frame/s)
mp -dither ham8 Glacier.mpg (alla fine ti mostra i frame/s)


Ho scaricato l'archivio di Seyia con mp e mpeg_play e il file glacier.mpg da aminet.
Tutti i test sono fatti sulla V4 standalone (è l'unico amiga aga al momento) sulla quale ho un core "lento" da 92 mips (77 mhz) con AGA

Solo i Test 5 e 7 sono stati eseguiti senza senza mostrare l'output a video. Il test5 per un limite di mp, il test 7 per vedere le prestazioni massime di RIVA.
Negli altri casi i risultati li ho ottenuti sempre col display attivo, vedendo l'animazione.

NOTA BENE: ho usato per tutti i test RIVA 0.53 in versione 68K. Questa versione è quella standard e NON USA le istruzioni aggiuntive della vampire.

Immagino che ora inizieranno le polemiche sul JIT della vampire (che sono una fantasia di Seyia),
ma i risultati sono riproducibili su un vero amiga col 68060@100 mhz (cioè, un A1200 col 68060 avrebbe suppergiù questi risultati).

-------------------------------
Test1:
> mpeg_play Glacier.mpg
Real time spent: 8.076172
Avg. Frames/sec: 23.525998
Framesize: 200x100 pixel
modeID: 0x29804 (PAL 640x512)


Test2:
> mp -dither ham8 Glacier.mpg
Framesize: 200x100
Avg. Frame/sec: 26.097921

Test3:
> RIVA-0.53 aga verbose Glacier.mpg
Video: 200x100 @ 23,976 , audio none
Total playback time: 7.8489
Displayed Framerate: 24.2070
----------------------------------

Poichè tutti i player raggiungono il framerate preimpostato nell'animazione,
ho eseguito di nuovo il test impostando fps=1000 o nodisplay:
----------------------------------

Test4:
> mpeg_play framerate=1000 Glacier.mpg
Real time spent: 4.211914
Avg. Frames/sec: 45.110132
Framesize: 200x100 pixel
modeID: 0x29804 (PAL 640x512)

Test5:
>mp -no_display glacier.mpg
Framesize: 200x100
Avg. Frame/sec: 51.621120

Test6:
> RIVA-0.53 aga noskip fps=1000 verbose Glacier.mpg
Video: 200x100 @ 23,976 , audio none
Total playback time: 2.3471 seconds
Displayed Framerate: 80.9496
---------------------------------------------- ----------------

Poi, dulcis in fundo, ho fatto il test con RIVA prima senza display epoi su RTG per vedere che impatto ha il rendering planar e quello chunky:
---------------------------------------------- ------------------------
Test7 (senza display - opzione norender):
Riva-0.53 aga noskip norender fps=1000 verbose glacier.mpg
Playback time = 1,2709 sec
Displayed framerate= 149.4944 fps

Test7 (display su picasso ):
Riva-0.53 dither=hicolor noskip fps=1000 verbose glacier.mpg
Playback time = 1,6154 sec
Displayed framerate= 117.6110 fps

Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
82.52.56.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36
Commento 53
Seiya 14 Marzo 2019    12:40:42
questi video io li ho fatti solo con il 68040 a 40 mhz. con il 68060 ne ho fatto di diversi che però non so dove reperire.
comunque fai il test con mpeg_play in NTSC 640x400 interlacciato. per vedere a parità di risoluzione. Vedo se ho il mio amico con il 68060 li aveva fatti. di solito facevano moltissimi benchmark con tutti i processori che ci sono capitati per le mani.

stavo ricontrollando una cosa: il player mpeg_play non va bene perchè era Amipeg v1.1 il test. l'ho scambiato per mpeg_play che una versione multi piattaforma che c'è anche per x86.
infatti avevo fatto i test tra 68030, 68040, 68060 e 486SX33 con lo stesso programma.

I video che hai fatto tu dovevi mandarti invece mp e amipeg1.1

comunque con amipeg con un 68040 a 40 Mhz, Glacier fa 15 fps, quindi un 68060 a 50 Mhz credo he faccia più di 20 (ora come detto, devo controllare se ho i risultati dello 060)


comunque tienti calda la standalone perchè ora preparo lo zippone con gli stessi test che ho fatto 20 anni fa. Devo fare una raccolta dei risultati e controllare un po'. Devo vedere quelli per 060.

Commento modificato il 14/03/2019 alle ore 12:47:25

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 54 in risposta al 53 di Seiya
cgugl 14 Marzo 2019    13:27:28
Citazione

stavo ricontrollando una cosa: il player mpeg_play non va bene perchè era Amipeg v1.1 il test. l'ho scambiato per mpeg_play che una versione multi piattaforma che c'è anche per x86.
infatti avevo fatto i test tra 68030, 68040, 68060 e 486SX33 con lo stesso programma.

Ho scaricato amipeg1.1 da aminet e nell'archivio c'è un eseguibile con lo stesso nome MPEG_PLAY e con la stessa dimensione.
Quindi amipeg = mpeg_play

Poichè ci sono le versioni 020, 040 e 060 le ho provate di nuovo su schermo NTSC, con identici risultati.
Dal doc ho visto che c'è il supporto CGX. L'ultimo test è su schermo RTG a 16 bit, dove mpeg_play apre una finestra (non è il massimo dalla vita)

Test9 (archivio amipeg1.1 da aminet, su AGA in modalità NTSC):
> mpeg_play.020fpu framerate=1000 framerate=1000 Glacier.mpg
Real time spent: 4,160156 sec
Avg. Frames/sec: 45.671362
Framesize: 200x100 pixel
modeID: 0x19804 (NTSC 640x400)

Test10 (archivio amipeg1.1 da aminet, su AGA in modalità NTSC):
> mpeg_play.040fpu framerate=1000 Glacier.mpg
Real time spent: 4,160156 sec
Avg. Frames/sec: 45,897617
Framesize: 200x100 pixel
modeID: 0x19804 (NTSC 640x400)

Test11 (archivio amipeg1.1 da aminet, su AGA in modalità NTSC):
> mpeg_play.060fpu framerate=1000 Glacier.mpg
Real time spent: 4,160156 sec
Avg. Frames/sec: 45.671362
Framesize: 200x100 pixel
modeID: 0x19804 (NTSC 640x400)

Test12 (archivio amipeg1.1 da aminet, su AGA in modalità CYBERGRAFIX):
> mpeg_play.020 dither cybergfx framerate=1000 Glacier.mpg
Real time spent: 3,179787 sec
Avg. Frames/sec: 60.123609
Framesize: 200x100 pixel
modeID: CYBERGRAFIX

You don't scare me devil, now I play :)

Post inviati: 5563

Visulizza profilo Messaggio Personale
46.141.119.*** Amiga-AWeb/3.5.09
Commento 55
amiwell79 14 Marzo 2019    13:57:16
penso sia inutile fare il test con amithlon che mi apre il file di 250 Mb su chiavetta con risoluzione di 856x482 a 1088p in un lampo e in full screen, meglio fare i test su macchina reale, poi ho scaricato qualche programmino da aminet ma sono obsoleti ed inadeguati

https://salvatore-abbate6.webnode.it/


Il Webmaster

Post inviati: 3197

Visulizza profilo Messaggio Personale
80.183.51.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 56 in risposta al 52 di cgugl
Mak73 14 Marzo 2019    17:29:54
Citazione


Ho scaricato l'archivio di Seyia con mp e mpeg_play e il file glacier.mpg da aminet.
Tutti i test sono fatti sulla V4 standalone (è l'unico amiga aga al momento) sulla quale ho un core "lento" da 92 mips (77 mhz) con AGA

Solo i Test 5 e 7 sono stati eseguiti senza senza mostrare l'output a video. Il test5 per un limite di mp, il test 7 per vedere le prestazioni massime di RIVA.
Negli altri casi i risultati li ho ottenuti sempre col display attivo, vedendo l'animazione.

NOTA BENE: ho usato per tutti i test RIVA 0.53 in versione 68K. Questa versione è quella standard e NON USA le istruzioni aggiuntive della vampire.

Immagino che ora inizieranno le polemiche sul JIT della vampire (che sono una fantasia di Seyia),
ma i risultati sono riproducibili su un vero amiga col 68060@100 mhz (cioè, un A1200 col 68060 avrebbe suppergiù questi risultati).



Se ho capito bene puoi fare i test senza l'output a video, se così è può farli anche Aleghid o sbaglio?

Nel caso dei test a video su Vampire StandAlone, in un certo senso non possono essere attendibili al massimo perchè tu non stai usando un vero AGA, ma una reimplementazione dello stesso, questo potrebbe portare a benefici che non possiamo valutare, quindi secondo me sarebbe preferibile proprio un output non a video. Anche in tal caso rimane da considerare che la Vampire, in particolare la standalone, immagino abbia un ottima velocità di accesso alla memoria paragonata a cosa può fare un vecchio Amiga espanso, questo sicuramente incide sulle prestazioni finali.

Per fare un esempio sul mio A4000 con CyberStorm MKIII, un conto erano le prestazioni utilizzando la ram sulla scheda madre, ben altra cosa se spostavi le simm sulla Cyberstorm, perchè ovviamente il controller di quest'ultima era notevolmente superiore a quello presente sulla scheda madre, di questo ovviamente il 68060 ne traeva un notevole vantaggio.

Come sempre fare paragoni di questo tipo è sempre difficile perchè intervengono moltissime variabili.

Pace e bene a tutti.

cgugl

Post inviati: 1849

Visulizza profilo Messaggio Personale
93.150.200.*** Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 57 in risposta al 56 di Mak73
cgugl 14 Marzo 2019    18:23:10
Citazione

Se ho capito bene puoi fare i test senza l'output a video, se così è può farli anche Aleghid o sbaglio?

Si. Quei programmi hanno tutti la possibilità di fare il rendering su AGA, su Scheda video RTG o di non fare alcun rendering. Aleghid potrebbe fare i test senza rendering a video o su RTG, così vediamo come va la V2 a parità di MHZ rispetto alla V4. (lo anticipo, a parità di frequenza la V2 dovrebbe essere più veloce della V4 nel 99% dei casi).

Citazione

Nel caso dei test a video su Vampire StandAlone, in un certo senso non possono essere attendibili al massimo perchè tu non stai usando un vero AGA

per motivi di compatibilità, la V4 stand alone accede alla "chip mem" come farebbe un vero 68030 su un vero amiga. La cache si spegne, la cpu rallenta fino alla velocità del 68030 e rispetta i sincronismi con gli altri chip custom. Infatti la V4 ha all'interno il suo gary e i chip 8520 tutti fedelmente riprodotti, quindi le temporizzazioni sono le stesse di un vero amiga.
I test con AIBB e con sysinfo dicono che l'accesso alla chip ram è identica a quella dell'accoppiata A4000 + CyberstormPPC

Se vogliamo verificarlo (sono curioso anche io di vedere se tutto va a dovere), dopo potrei provare a disattivare la fast mem e ad eseguire di nuovo mpeglay da chipmem.

Confermo, la V4 si comporta come un vero amiga:
---------------------------------------------- -------------------
Test13 (V4 stand alone in modalità aga senza fastmem, con rendering a video su AGA)
> mpeg_play framerate=1000 Glacier.mpg
Real time spent: 65,040039 sec
Avg. Frames/sec: 2.921277
Framesize: 200x100 pixel
modeID: 0x29804 (PAL 640x512)

Commento modificato il 14/03/2019 alle ore 18:38:44

Post inviati: 1324

Visulizza profilo Messaggio Personale
5.90.15.*** Mozilla/5.0 (Linux; Android 9; G8341) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Mobile Safari/537.36
Commento 58
aleghid 14 Marzo 2019    18:58:21
Ragazzi tra poco vado a lavorare. Appena ho un po di tempo li faccio.

Il Webmaster

Post inviati: 3197

Visulizza profilo Messaggio Personale
80.183.51.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
Commento 59 in risposta al 57 di cgugl
Mak73 14 Marzo 2019    21:19:52
Citazione

per motivi di compatibilità, la V4 stand alone accede alla "chip mem" come farebbe un vero 68030 su un vero amiga. La cache si spegne, la cpu rallenta fino alla velocità del 68030 e rispetta i sincronismi con gli altri chip custom. Infatti la V4 ha all'interno il suo gary e i chip 8520 tutti fedelmente riprodotti, quindi le temporizzazioni sono le stesse di un vero amiga.
I test con AIBB e con sysinfo dicono che l'accesso alla chip ram è identica a quella dell'accoppiata A4000 + CyberstormPPC

Se vogliamo verificarlo (sono curioso anche io di vedere se tutto va a dovere), dopo potrei provare a disattivare la fast mem e ad eseguire di nuovo mpeglay da chipmem.



Ovviamente hanno avuto diversi accorgimenti per mantenere la compatibilità, dubito però che il chip AGA sia fedelmente riprodotto, in quanto si potrebbe incorrere in violazioni di brevetti, ma anche tralasciando tale particolare, riproducendolo fedelmente ma con tecnologie odierne risulterebbe sicuramente più veloce, per questo credo che sia una reimplementazione, cioè è in grado di eseguire tutte le istruzioni del chipset originario ma è diverso a livello hardware, un po' come x86 Intel è diverso da un x86 AMD, pur essendo compatibili a livello di codice, non so se mi spiego.

Ritengo che tale reimplementazione si sia resa necessaria proprio per mantenere i sincronismi da te citati, la cui mancanza avrebbe causato molte incompatibilità.
Credo che il dover mantenere la compatibilità abbia portato e molte soluzioni volte molto spesso a rallentare le prestazioni, ad esempio anche a livello di memorie, sicuramente la Vampire monta chip più moderni e veloci, che però per i motivi citati non sono sfruttate al massimo.

Nell'accesso alla chip ram l'A4000 con Cyberstorm si differenziava poco rispetto ad un A4000 con altra scheda acceleratrice, questo perchè purtroppo la chip rimaneva sulla scheda madre e quindi ci si ritrovava a dover passare sempre attraverso al controller di serie, che purtroppo era piuttosto penoso.

Pace e bene a tutti.

Pegasus RyuSei Ken

Post inviati: 8714

Visulizza profilo Messaggio Personale
80.116.42.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36
Commento 60
Seiya 14 Marzo 2019    21:20:32
Ecco lo zippone. Dentro c'è un file di testo che spiega come farli e perchè farli. Usate i file che ci sono qui dentro. Peccato non abbia trovato i video che abbiamo provato il 68060. Chissà dove li avevo presi...

Commento modificato il 14/03/2019 alle ore 21:24:23

Pagine: -1-2- [3] -4-

Utenti Online
Utenti registrati: 958 dal 1 Gennaio 2006
di cui online: 5 registrati - cgugl - amiwell79 - Oge - DrProcton - galvanica -
14 non registrati

Benvenuto all'ultimo utente registrato: Rocketpl

Buon Compleanno a Swichtblade - mauro2671 - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.14334917068481 secondi