Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


23 Giugno 2018 Postato da: SukkoPera
Sostituire Batteria A500+ con CR2032
Volevo postare una modifica che ho recentemente effettuato su un 500+ per usare una comune batteria "a bottone" CR2032 NON ricaricabile al posto di quella di serie.

Di per sé la cosa non è niente di nuovo ( su AmiNet fa 20 anni proprio tra pochi giorni ), quel che è interessante è il modo in cui l'ho fatto, con un lavoro molto "pulito".

Infatti, ho notato per puro caso che i portabatteria che si usano sull'espansione RAM fai-da-te (noti come BS-7 e dal costo irrisorio) hanno praticamente lo stesso passo della dannata batteria Varta che ha distrutto tanti Amiga, di conseguenza risulta molto facile sostituirlo ad essa.

Immagine

Visto che vogliamo usare una batteria non ricaricabile è necessario aggiungere un diodo

->Continua<-

Commenti: 28  Aggiungi - Pagine: 1-2


Pagine: -1- [2] -

Temibile Pirata

Post inviati: 535

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Commento 21 in risposta al 16 di Oge
SukkoPera 3 Luglio 2018    10:30:52
Citazione

In quel kit limitano la tensione con uno zener. Direi uno zener 2V2, che è un ottimo approccio e fornisce una tensione vicinissima a quella richiesta.

Sulla mia 500+ proverò così, con uno zener non minore di 1W.

Per chi vuole provare, zener 2V2 500mW (non fate i tirchi con uno 250mW, meglio sempre un pò di headroom).



A me non pare proprio che siano degli Zener, per almeno due motivi:

1. Uno Zener deve sempre avere un resistore in serie per mantenere la corrente in un determinato range, fuori dal quale l'effetto Zener non si verifica. Il calcolo di tale resistore non è nemmeno troppo banale, tra l'altro.

2. Sul diodo si legge abbastanza chiaramente un 48, che sembrerebbe indicare sia un 1n4148, uno dei diodi più comuni dell'universo (tra l'altro è molto simile all'1n914, altro diodo comunissimo in passato):

Immagine


Francamente continuo a non vedere la necessità di queste soluzioni arzigogolate. Forse pensi che forzando la tensione a 2.2V la batteria si scarichi più lentamente, ma non è così, perché la tensione in eccesso non "rimane nella batteria", ma viene bensì dissipata sul resistore in serie che ogni Zener DEVE avere.

Quindi di fatto la soluzione di AmigaStore è uguale alla mia, solo "pronta" da montare, ma più costosa .

Tra l'altro, da datasheet si desume che a 3V l'RTC consuma circa 15 uA (microampere). Una CR2032 normale ha almeno 200 mAh (milliampere-ora), per cui durerà ALMENO un paio d'anni, più probabilmente 4-5. Mi sembra davvero inutile preoccuparsi della sostituzione di questa batteria, mi preoccupa di più dimenticarla dentro ad un Amiga quando lo metto "in magazzino", per quanto effettivamente questo tipo di batterie solitamente non perda acido.

Attenzione alle soluzioni con batteria ricaricabile: le LIR2032 sono al Litio e, come dice majinga, avrebbero bisogno di un circuito di ricarica diverso da quello presente su Amiga, che è progettato per batterie NiCd. Probabilmente alla fine funziona comunque, ma se dovessere succedere qualcosa di poco piacevole (ricordo che le batterie al litio prendono "facilmente" fuoco) non mi stupirei.

Concordo che la soluzione con i fili volanti funziona, per carità, ma è poco bella e può causare cortocircuiti se il portabatteria va a finire dove non deve. Ribadisco che il senso della mia proposta era quello di fare una mod semplice, rapida, pulita e bella a vedersi.

Commento modificato il 03/07/2018 alle ore 12:18:13


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Temibile Pirata

Post inviati: 535

Visulizza profilo Messaggio Personale
91.253.182.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 22
SukkoPera 3 Luglio 2018    11:22:34
Nel frattempo ho fatto la modifica anche su due espansioni. Una dovrebbe essere una A501 originale, mi è arrivata come la vedete. Non so se sia stata rimossa la copertura di metallo o se ce ne fossero anche così, solo scheda.

La modifica è la stessa di cui sopra. Le differenze sono minime:
- Sulla A501 originale (scheda più chiara) la batteria originale era ancorata unicamente ai due fori laterali, quello centrale ho dovuto farlo io.
- Sulla scheda più scura (se non ricordo male la comprai da Kyle tempo fa) idem, ma c'è l'ulteriore complicazione che il nuovo foro (che porta il polo positivo) va a finire in mezzo ad un piano di massa. Per questo ho dovuto in qualche modo isolare la zona, "scavando" due solchi a V.

Il posizionamento dei diodi può sembrare bizzarro, ma ho deciso di cogliere il suggerimento di Mck di metterli al posto delle resistenze. Non so perché le posizionassero in questi modi improvvisati invece di prevedere i relativi fori e piste, mah!

Immagine
Immagine

PS: Non le ho ancora collaudate .

Commento modificato il 03/07/2018 alle ore 12:11:19


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 1107

Visulizza profilo Messaggio Personale
82.55.79.*** Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36
Commento 23
Oge 3 Luglio 2018    12:31:52
Risultato molto bello. Devo informarmi circa la soluzione con lo zener e credo proprio che quello usato nel kit, come da te indicato, sia uno 1N148.

Commento modificato il 03/07/2018 alle ore 12:36:12

Post inviati: 1423

Visulizza profilo Messaggio Personale
151.29.146.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36
Commento 24
Kyle 3 Luglio 2018    20:11:42
Davvero te l'ho venduta io la scheda più scura? non me lo ricordo

Comunque la A501 originale è stata spogliata del suo shield metallico, veramente rognoso da rimuovere se non si ha la strumentazione adatta perché c'è un botto di stagno a tenere uniti il bottom shield e la parte superiore.

Hai dovuto tagliare la pista che mi dicevi via mail prima di installare il battery holder?

Questa è la foto della mia A501, come sai anche io voglio fare la tua stessa modifica

Immagine

Post inviati: 1957

Visulizza profilo Messaggio Personale
151.32.189.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Commento 25
Mck 4 Luglio 2018    10:10:28
Kile quando metti il porta batteria devi lasciare lo spazio laterale altrimenti tocca nel bordo di plastica sul case del 500.
Io metto il porta batteria sfruttando i fori della vecchia batteria. Dal lato con i due fori sfrutto quello verso il centro del circuito stampato (il porta batteria resta storto ma non tocca nel bordo).
Il diodo lo saldo al posto della resistenza da 470 ohm (fasce colori giallo-viola-marrone-oro) R913.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

Temibile Pirata

Post inviati: 535

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Commento 26 in risposta al 24 di Kyle
SukkoPera 4 Luglio 2018    10:12:41
Citazione

Davvero te l'ho venduta io la scheda più scura? non me lo ricordo

Comunque la A501 originale è stata spogliata del suo shield metallico, veramente rognoso da rimuovere se non si ha la strumentazione adatta perché c'è un botto di stagno a tenere uniti il bottom shield e la parte superiore.

Hai dovuto tagliare la pista che mi dicevi via mail prima di installare il battery holder?

Questa è la foto della mia A501, come sai anche io voglio fare la tua stessa modifica

Immagine




Sì, ho recuperato i PM e me l'avevi venduta tu! Ricordavo bene .

Sulle espansioni non ho dovuto tagliare nessuna traccia. Come dicevo, la resistenza che collegava la batteria al circuito su entrambe le espansioni era montata "volante", per cui rimuovendola la batteria era già isolata dal circuito ed è bastato mettere il diodo al suo posto.

Sulla tua espansione, però, la resistenza sembra essere messa "bene", segui quel che dice Mck.

Commento modificato il 04/07/2018 alle ore 10:28:54


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 1423

Visulizza profilo Messaggio Personale
93.147.189.*** Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Version/9.0 Mobile/13G36 Safari/601.1
Commento 27
Kyle 4 Luglio 2018    13:50:33
Va bene grazie a entrambi

Temibile Pirata

Post inviati: 535

Visulizza profilo Messaggio Personale
37.227.21.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 28
SukkoPera 11 Luglio 2018    10:27:49
Ho testato le mie espansioni modificate e funzionano benissimo, sia come tenuta del clock che a livello di inserimento fisico.

Sull'espansione scura penso ci sia un chip guasto, probabilmente dovuto alla perdita della batteria che c'è stata in passato. Dovrei averlo già identificato e rimosso, sono in attesa di un chip nuovo dalla Spagna.

Immagine

Commento modificato il 11/07/2018 alle ore 10:28:35


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Pagine: -1- [2] -

Utenti Online
Utenti registrati: 867 dal 1 Gennaio 2006
di cui online: 2 registrati - Diabloxxx - liviux76 -
13 non registrati

Benvenuto all'ultimo utente registrato: 

Buon Compleanno a Cattleya - tirello75 - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.063613176345825 secondi