Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


24 Ottobre 2012 Postato da: Pericle76
Modificare lettori floppy per PC da usare su AMIGA (aggiornamento 2018)
Cari Amighisti, spero di fare cosa gradita riportando le mie esperienze personali sulla modifica dei Lettori di Floppy per PC per poterli utilizzare sui nostri AMIGA.

Come molti sanno quasi tutti i lettori di Floppy per PC sono modificabili, alcuni interagendo su ponticelli altri intervendo con taglio piste e saldature.

I passaggi fondamentali sono Tre:

1- Commutare il lettore da DS1 (PC) a DS0 (AMIGA)
2- Veicolare il segnale "Disk Ready" (RDY) al pin 34
3- Veicolare il segnale "Disk Change" (DC) al pin 2

Di seguito Troverete le guide per Modificare:

Sony MPF920 Z/131
Samsung SFD-321B
ALPS Elecronic DF354

Presto se va a buon fine posterò anche la modifica di un Mitsumi.

Cominciamo Con il Sony

Immagine

Immagine

Come potete vedere dalla foto bisogna procedere in questo modo:

1 - Tagliare la pista che dal pin 34 va al Disk Change
2 - Saldare un ponticello tra il DC (punto B) e il pin 2
3 - Saldare un ponticello tra il RDY (pin 18 del chip in alto a destra) e il pin 34
4 - Sposare la resistenza da 0 Ohm da JC31 a JC30 (punto A) per passare da DS1 a Ds0

Altra variante

Immagine

Immagine

Come potete vedere dalla foto bisogna procedere in questo modo:

1 - Tagliare la pista che dal pin 34 va al Disk Change
2 - Saldare un ponticello tra il DC (punto B) e il pin 2
3 - Saldare un ponticello tra il RDY e il pin 34
4 - Sposare la resistenza da 0 Ohm da JC31 a JC30 (punto A) per passare da DS1 a Ds0

Passiamo al Samsung

Immagine


Immagine

Sempre guardando la foto:

1 - Spostare la resistenza da 0 Ohm dal Punto A al Punto B (in questo modo avremo già il RDY sul pin 34)
2 - Saldare un ponticello tra il DC e il pin 2
3 - Spostare il ponticello (saldatura) da DS1 a DS0 (punto C)


Spero che Pericle76 non si offenda per avergli aggiunto altre modificke ai driver floppy

->Continua<-

Commenti: 339  Aggiungi - Pagine: 1...-13-14-15-16-17


Pagine: -1-2-3-4-5-6-7-8-9- [10] -11-12-13-14-15-16-17-

Temibile Pirata

Post inviati: 1193

Visulizza profilo Messaggio Personale
91.252.39.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.80 Safari/537.36
Commento 181
SukkoPera 5 Giugno 2019    21:44:29
Ottimo! Dovresti provare il famoso demo Sanity's Arte , è molto pignolo sulla lettura del disco.

Commento modificato il 05/06/2019 alle ore 21:47:31


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Loom4ever

Post inviati: 176

Visulizza profilo Messaggio Personale
151.26.61.*** Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/9.2 Chrome/67.0.3396.87 Mobile Safari/537.36
Commento 182
Loom4ever 5 Giugno 2019    22:37:39
Ragazzi siete dei grandissimi

@SukkoPera
Confermo la mia opinione su di te...spacchi di brutto con l'Amiga

@liviux76
Quando hai terminato tutto pubblichi la foto della board?
Dai che voglio segnalarla sul forum inglese coi vostri nomi

Immagine

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 183
liviux76 6 Giugno 2019    00:10:03
Il merito è sicuramente di sukkopera non mio... nemmeno so cos'è un diodo...

Comunque... la buona notizia come detto è che l'Alps se lo metto come DF0: non sembra avere nessun problema.
Ovvio che un uso intensivo sarebbe più indicato, magari provando ad installare giochi originali con whdload, leggendo floppy con demo come quella consigliata da sukkopera (ce l'ho da qualche parte, cercherò di fare anche quello... ), etc... ma per ora direi che si è comportato bene nei test "standard" di uso sotto WB e con XCopy.

Dato che c'ero ho provato anche ad usarlo come DF1: con questa nuova modifica.
Il risultato è stato discreto... mi spiego meglio. Se usato come DF1: senza un ulteriore DF2: in catena va benissimo. Sia il DF0: che il DF1: leggono e scrivono senza problemi.
Quando però ho aggiunto un secondo drive esterno ho riscontrato dei problemi con XCopy. Sia che l'Alps fosse DF1: che DF2:, la scrittura contemporanea sui drive esterni era molto lenta. La formattazione di due dischi privi di errori (già formattati più volte durante le prove) ha richiesto più di 3 minuti quando in genere ce ne vogliono 1:47. Durante la formattazione, in ogni settore prima di apparire lo 0 in verde appariva un 8 in rosso.

A parte questo problema penso che possiamo ritenerci abbastanza soddisfatti. Sicuramente così il drive è utilizzabile, come DF0: è perfetto e come DF1: senza ulteriori drive esterni pure.
Ho poi fatto le prove di lettura e scrittura con Kaf Systest (AmigaTestKit come si chiama ora) e le ha passate. Ho provato due drive Alps, prima uno impostato come DF0: e l'altro come DF1: e poi invertendoli e ho notato una cosa "curiosa", uno dei due ha il ready "too fast" (comune nei drive PC modificati) e l'altro "too slow". Il risultato era lo stesso sia quando erano impostati come DF0: che come DF1: quindi i due drive che dovrebbero essere identici e modificati in modo identico hanno "tempi di reazione" differenti. Misteri...

Qui ho messo le foto delle due pcb modificate (poi ne ho modificata una terza il cui ready era "too fast" come avviene di solito) e le foto del messaggio del Kaf Systest.
Per ora direi che è tutto... grazie ancora dei suggerimenti, mi sono abbastanza divertito...

Commento modificato il 06/06/2019 alle ore 00:13:26

Temibile Pirata

Post inviati: 1193

Visulizza profilo Messaggio Personale
62.11.75.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 184
SukkoPera 6 Giugno 2019    00:31:44
Non vedo come il ready possa essere troppo lento o differire tra un drive e l'altro, visto che di fatto in questo modo lo fai generare ad Amiga stesso e tagli completamente fuori dal discorso il drive. Probabilmente non hai isolato bene il pin 34 dalla connessione precedente, il che sembrerebbe confermato dal fatto che il test kit ti dice che il segnale oscilla. Prova a verificare.

Comunque non ho alcun merito, se ho suggerito questa cosa è perché probabilmente l'ho letta da qualche parte tempo addietro. Quando farò il mio adattatore, allora me ne prenderò i relativi meriti .

È strano che non funzioni bene come DF2: (mi aspettavo che proprio non fosse riconosciuto, al massimo). Non è che anche l'altro drive è moddato e ha un /RDY strano?

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Loom4ever

Post inviati: 176

Visulizza profilo Messaggio Personale
5.90.170.*** Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/9.2 Chrome/67.0.3396.87 Mobile Safari/537.36
Commento 185
Loom4ever 6 Giugno 2019    06:46:14
Io i vostri nomi li metto poi rosicassero gli altri. É una questione personale ragazzi, ci sono troppi cazzari nel settore e si fanno pagare pure bene.
Io stesso in passato per mancanza di tempo ho affidato della componentistica Amiga a pseudotecnici che si pubblicizzano su Internet come centri specializzati in riparazioni per Commodore. Non solo scopiazzavano le soluzioni dai forum ma non avevano manco gli Amiga per testare i componenti. Cioè "riparavano" ma testavano probabilmente col tester e poi rispedivano avvisando che non avevano un Amiga e quindi amen.
Gli ultimi li ho dovuti diffidare, dopo di che mi son detto oh sai che ti dico? Ho assemblato quando ero studente tanti pc, se il livello é così basso e superficiale mi ritaglio un cavolo di tempo pure a notte fonda e cerco di arrangiare io!
A sto punto se mi devono rovinare di più le mie cose sti personaggi me le sfascio con le mie mani!
E poi sapete quanta gente leggerà questo topic e se li andrà a vendere anche a 40-50 euro?

Comunque tornando al diverso comportamento di identici drive... non é che il numero di revisione é diverso?
Anzi già che ci siamo liviux76 puoi scrivere i numeri di revisione su cui hai fatto le mod?
Per la cronaca il mio modello é rev 121G.

Commento modificato il 06/06/2019 alle ore 06:48:11


Immagine

Temibile Pirata

Post inviati: 1193

Visulizza profilo Messaggio Personale
62.11.75.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 186
SukkoPera 6 Giugno 2019    08:32:20
Ma non è proprio possibile nel senso che il segnale non arriva mai al drive, Amiga lo genera e Amiga lo riceve. Il diodo potresti saldarlo anche direttamente sulla mainboard Amiga e ti direbbe che il drive è pronto persino quando non è montato...

Commento modificato il 06/06/2019 alle ore 08:33:27


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 2471

Visulizza profilo Messaggio Personale
151.33.126.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Commento 187
Mck 6 Giugno 2019    08:37:51
La butto li perchè mi è capitato un lettore floppy esterno dato per non funzionante.
Durante le mie provo mi ha fuso pure un cia. Ho poi controllato i fili di collegamento tra la presa DB25 e il PCB del driver esterno e i fili erano quasi tutti in posizione sbagliata.
Dopo un riposizionamento corretto dei fili è tornato funzionante.
Dico questo perchè sul connettore esterno per attaccare un altro floppy esterno devono essere spostati di posizione i segnali _SEL.
_SEL1 deve andare al driver contenuto nel primo box esterno _SEL2 deve diventare _SEL1 sul connettore esterno del primp driver e via di seguito per _SEL3.
Spero di essere stato chiaro.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 188
liviux76 6 Giugno 2019    12:50:39
Per quanto riguarda il "too slow" aveva come sempre ragione sukkopera... c'era un piccolo contatto tra il pin 10 dove avevo saldato il diodo e il pin 8.
Il drive funzionava lo stesso ma con Kaf Systest avevo notato quella "stranezza" e adesso invece il drive è visto come gli altri (Gotek or hacked PC drive).

Ho testato anche i Samsung con Kaf Systest e finora sono gli unici che non vengono visti come Gotek or hacked PC drive, il ready è ok come se fossero drive Amiga nativi. Quando avrò tempo proverò anche l'unico Sony che ho con Kaf Systest per vedere come si comporta.

Ho preso ispirazione dal lavoro sull'Alps per modificare un NEC FD1231H che funzionava ma che anche lui aveva qualche difettuccio e ora mi sembra quasi perfetto. Lui non "rallenta" gli altri drive se usato come DF1: o DF2:, l'unica cosa strana che ha è che quando con Kaf Systest provo il signal anziché fermarsi a 1 (in alcuni casi ho visto che si ferma anche a 2), il test va avanti all'infinito.

Non so se questa è una cosa di cui preoccuparsi o meno, per il resto scrive, legge e non disturba gli altri drive.
Questa la modifica (praticamente un mix delle varie modifiche che ho trovato in rete e che avevano tutte vari problemi):

- Tagliare la traccia che va dal pin 6 del IC FDN305 al pin 34 del connettore floppy
- Tagliare la traccia che va dal pin 19 del IC FDN305 al pin 12 del connettore floppy
- Tagliare la traccia che va dal pin 2 del connettore floppy al pad inferiore della piazzola R1

- Saldare un filo dal pin 6 del IC FDN305 al pin 2 del connettore floppy
- Saldare un filo dal pin 19 del IC FDN305 al pin 10 del connettore floppy
- Saldare un diodo (1N4148) dal pin 34 del connettore floppy al pin 10 del connettore floppy (con il catodo verso quest'ultimo)

Purtroppo ne ho solo due e mentre su uno ha funzionato sull'altro ho qualche problema ma non riesco a capire da cosa possa essere causato... se qualcuno ha uno di questi floppy a disposizione mi farebbe piacere sapere se quest modifica funziona.

Questa la foto, appena riesco metto dei cerchietti per evidenziare i vari punti:

Immagine

Commento modificato il 06/06/2019 alle ore 12:51:17

Temibile Pirata

Post inviati: 1193

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
Commento 189 in risposta al 188 di liviux76
SukkoPera 6 Giugno 2019    13:05:16
Citazione

Ho testato anche i Samsung con Kaf Systest e finora sono gli unici che non vengono visti come Gotek or hacked PC drive, il ready è ok come se fossero drive Amiga nativi.


Il Samsung ha un vero segnale di ready, per questo sembra comportarsi correttamente, non bisogna inventarselo in qualche modo come stiamo facendo con l'ALPS. Probabilmente c'è anche su quasi tutti gli altri drive, ma se non sappiamo dov'è...

Ricordo che il segnale /RDY viene asserito (= messo a 0) quando il disco sta ruotando alla velocità corretta, questo è il suo è significato. Sui drive dell'epoca questo avviene entro 200-300 ms dall'accensione del motore, o perlomeno mi sembra che queste siano le tempistiche che si aspetta Systest. Nel caso della mod con il diodo, come spiegavo, il /RDY è lo stesso segnale di selezione del drive che torna indietro, quindi è sostanzialmente istantaneo, per cui Systest misura pochi NANOsecondi (che in pratica è il tempo di esecuzione del codice che legge il segnale ) e si "lamenta" che è troppo veloce.

Ricordo anche che questo segnale NON è più di tanto fondamentale per la corretta lettura dei floppy. La maggior parte dei programmi aspettano semplicemente che arrivino i dati, non stanno lì a monitorare i segnali. Alcuni programmi però sono rompiballe e invece fanno più o meno le pulci su ste cose. Il più famose esempio è il demo Arte di cui parlavo prima, ma anche X-Copy va in fissa su qualche segnale.

Commento modificato il 06/06/2019 alle ore 13:27:18


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 987

Visulizza profilo Messaggio Personale
79.22.223.*** Mozilla/5.0 (Linux; Android 8.1.0; TA-1032) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Mobile Safari/537.36
Commento 190
majinga 6 Giugno 2019    13:52:42
Io non capisco come fa a funzionare come drive esterno. E tutta la storia sull'id di identificazione?

Tornando a parlare di un eventuale adattatore. Mettere un delay non è difficile. Come circuito di riferimento si può prendere in considerazione il circuito del reset. Che fa esattamente quello, introduce un ritardo sul segnale.
Se non vado errato un ritardo accettabile sui floppy è circa 300mS. Il circuito del reset è più lento, è impostato su circa mezzo secondo. Ma quello si regola. Oppure si può lasciare così, in modo da essere sicuri che perfino i drive lenti siano pronti.
Rimane la cosa dell'identificazione. Nel senso, magari sono tutti circuiti semplici presi singolarmente, ma è da vedere quanta roba serve per fare un adattatore fatto bene.

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 191
liviux76 6 Giugno 2019    14:08:53
Grazie ancora per le spiegazioni, sukkopera, come dicono gli inglesi, much appreciated

Un adattatore "fatto bene" per tutti i modelli non so se sarebbe possibile, i drive per PC sono piuttosto diversi gli uni dagli altri ed infatti ero sorpreso di come l'adattatore che ho preso li facesse funzionare tutti... solo che mi sono limitato a testarli come df0: senza altri drive collegati e ho letto e formattato giusto un paio di floppy ogni volta... così non ho riscontrato problemi ma ovviamente le magagne vengono fuori dopo, come abbiamo visto.

Comunque ho testato Arte sull'Alps, nessun problema, demo eseguita sino alla fine e quando stava re-iniziando l'ho interrotta... direi che così va benone. Per la cronaca anche sul NEC ho letto Arte e va bene, il difetto che riscontro sul NEC e che cercavo di spiegare prima è che in Kaf Systest quando avvio il "signal test" questo normalmente si ferma a "0 index pulses" mentre utilizzando questo drive il conteggio degli "index pulses" va avanti ininterrottamente. Metto di seguito una foto per far capire meglio che intendo.

Immagine

Nell'uso non ho però riscontrato alcun problema, potrebbe essere qualcosa di cui preoccuparsi o posso considerare anche il NEC "abile e arruolato"?

Post inviati: 2471

Visulizza profilo Messaggio Personale
151.33.126.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Commento 192
Mck 6 Giugno 2019    15:01:32
@majinga
La cosa più semplice per fare un ritardo, visto che non serve una precisione estrema e mettere una resistenza sul segnale _RDY che dovrebbe generare il lettore o meglio il senale _SEL, pin 10. sull'altro lato della resistenza un condensatore con l'altro polo a massa.
La congiunzione della resistenza e del condensatore va collegato al pin 34, _RDY.
La resistenza carica il condensatore quando alla resistenza non arriva più tensione il condensatore si scarica sulla resistenza e dopo un po di tempo _RDY va a massa.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

Post inviati: 987

Visulizza profilo Messaggio Personale
79.22.223.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0
Commento 193
majinga 6 Giugno 2019    15:18:41
In questo modo il ritardo ci sarebbe sia sul fronte di salita che di discesa, ed è possibile che questa cosa crei dei problemi, sui segnali digitali è importante che i segnali abbiano delle tempistiche corrette.
Non dico che non funziona, ma sarebbe formalmente non corretto.

Temibile Pirata

Post inviati: 1193

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
Commento 194
SukkoPera 6 Giugno 2019    15:32:49
Un semplice ritardo potrebbe funzionare, però secondo me un approccio migliore è un circuito che conta un certo numero di impulsi del segnale /INDEX.

Infatti, e qua mi riallaccio a quanto segnalato da liviux, il segnale /INDEX è normalmente alto e dà un impulso basso ad ogni rotazione del disco. Contare 2-3 impulsi dopo l'attivazione del motore dovrebbe essere un modo più corretto di garantire che la rotazione è ormai stabile, piuttosto che aspettare un ritardo fisso. Anche perché credo che il ritardo NON si dovrebbe avere quando il motore viene disattivato: qui /RDY dovrebbe tornare alto subito, senza ritardi. Al solito, bisognerebbe guardare con il LA.

Ho buttato giù 2 righe di Verilog che fanno questo, potrebbe essere un buon progetto per iniziare con le CPLD...

Quanto al problema di liviux nello specifico: dovrebbe ora essere chiaro che se l'index count cresce all'infinito è perché il disco continua a girare. Questo potrebbe voler dire che il drive non riconosce il comando di stop del motore? Con gli altri drive si ferma? (1 o 2 conta poco, vuol dire un giro in più o in meno, l'importante è che si fermi in un tempo ragionevole).

Citazione

Io non capisco come fa a funzionare come drive esterno. E tutta la storia sull'id di identificazione?


Presumo che lo inserisca in un box che ha l'adeguata circuiteria per l'ID .

Commento modificato il 06/06/2019 alle ore 15:39:00


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 987

Visulizza profilo Messaggio Personale
79.22.223.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0
Commento 195 in risposta al 194 di SukkoPera
majinga 6 Giugno 2019    15:48:27
Citazione

Un semplice ritardo potrebbe funzionare, però secondo me un approccio migliore è un circuito che conta un certo numero di impulsi del segnale /INDEX.

Infatti, e qua mi riallaccio a quanto segnalato da liviux, il segnale /INDEX è normalmente alto e dà un impulso basso ad ogni rotazione del disco. Contare 2-3 impulsi dopo l'attivazione del motore dovrebbe essere un modo più corretto di garantire che la rotazione è ormai stabile, piuttosto che aspettare un ritardo fisso. Anche perché credo che il ritardo NON si dovrebbe avere quando il motore viene disattivato: qui /RDY dovrebbe tornare alto subito, senza ritardi. Al solito, bisognerebbe guardare con il LA.


Si, l'approccio del ritardo è più o meno lo stesso del RDY generato a prescindere dal drive. Si parte dal presupposto che non si è sicuri che ogni drive presenti tutti i segnali o che possano non essere proprio come uno se li aspetta.

Post inviati: 2471

Visulizza profilo Messaggio Personale
151.33.126.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Commento 196
Mck 6 Giugno 2019    15:55:12
Altro problema che potrebbe dare segnali diversi è un caso che ho notato.
Provando diversi lettori floppy tutti originali amiga ho notato che il numero dei giri, che dovrebbe essere 300 al minuto, variano dai 300 ai 310 e i driver funzionano perfettamente.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 197
liviux76 6 Giugno 2019    17:21:13
Sì, forse non l'avevo scritto ma chiaramente quando testo i drive come DF1:, DF2:, etc... li sto usando collegati a un box di un floppy esterno, tipo quello del 1011, per intenderci, ma non di marca Commodore.
Confermo che l'Alps dà il problema del rallentamento se messo come DF1: con un DF2: collegato "a catena".
Questo capita se si usano DF1: e DF2: insieme non se si usa, ad esempio, il DF1: e il DF0: o il DF2: e il DF0:

Chiarifico con uno schema:

DF0: Floppy Samsung / Teac Nativo
DF1: ALps
DF2: Teac Nativo

Formatto con XCopy 2 floppy disk contemporaneamente su:

DF0: / DF1: = ~ 1m 47s
DF0: / DF2: = ~ 1m 47s
DF1: / DF2: = ~ 2m 50s / ~3m 05s

Usati singolarmente funzionano tutti bene (tempo di formattazione ~ 1m 11s).

Altro problema, se si prova a formattare senza aver inserito il floppy nell'unità, di regola XCopy dice "No Disk in DF0: !" mentre se si prova a formattare senza aver inserito il floppy nel drive Alps XCopy dice "Verify Error on Disk DF1: (R/C)". La sostanza è la stessa ma non si accorge che non c'è il disco inserito nel drive ma solo che c'è qualcosa che non va.

Passiamo alle cose positive invece...
Se si inseriscono dischi HD (con il secondo foro), il drive Alps funziona comunque correttamente, cosa che non capita con molti drive modificati. Questo perché sull'Alps è semplice fare la modifica che disattiva il sensore HD.
Altra cosa positiva... se si usano due drive esterni con l'Alps come DF2: non ci sono rallentamenti. Nuovo schema esemplificativo:

DF0: Floppy Samsung / Teac Nativo
DF1: Teac Nativo
DF2: ALps

Formatto con XCopy 2 floppy disk contemporaneamente su:

DF0: / DF1: = ~ 1m 47s
DF0: / DF2: = ~ 1m 47s
DF1: / DF2: = ~ 1m 47s

Tempo di formattazione contemporanea di 3 floppy disk ~ 2m 25s. Usati singolarmente funzionano tutti bene (tempo di formattazione ~ 1m 11s).
Con questo direi che per l'Alps è tutto...

Loom4ever

Post inviati: 176

Visulizza profilo Messaggio Personale
151.26.42.*** Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/9.2 Chrome/67.0.3396.87 Mobile Safari/537.36
Commento 198
Loom4ever 6 Giugno 2019    18:19:05
@liviux76
Ottimo lavoro

Non ho capito qual é l'immagine del pcb finale e definitivo. Per intenderci quello relativo alla mod perfettamente funzionante con gli ultimi test e combinanzioni che hai appena scritto.
Puoi postarla?

Oggi vado in un negozio di elettronica in zona e cerco un diodo intanto.

Immagine

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 199
liviux76 6 Giugno 2019    21:02:02
La foto non è eccellente ma qui l'ho uploadata con una risoluzione maggiore:

Immagine

Questa la "guida definitiva" per convertire il Floppy Drive per PC Alps DF354 per l'utilizzo su Amiga

- Tagliare la traccia che va dal pin 5 del IC ALPS-R SD705A al pin 34 del connettore floppy (cerchio blu a sx)
- Tagliare la traccia che va dal pin 19 del IC ALPS-R SD705A al pin 2 del connettore floppy (cerchio blu a dx)
- Aprire il pad DS1 e chiudere il pad DS0 (cerchio viola)

- Saldare un filo dal pin 5 del IC ALPS-R SD705A al pin 2 del connettore floppy (cerchi bianchi)
- Saldare un filo dal pad HD2 al pad MIS (cerchi verdi)
- Saldare un diodo (1N4148) dal pin 34 del connettore floppy al pin 10 del connettore floppy (con il catodo verso quest'ultimo) (cerchi rossi)

Adesso provo a fare anche quella per il NEC...

liviux76

Post inviati: 621

Visulizza profilo Messaggio Personale
151.42.178.*** Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 200
liviux76 6 Giugno 2019    22:07:25
Ok, foto e guida per la modifica del drive NEC FD1231H per l'uso su Amiga:

Immagine

- Tagliare la traccia che va dal pin 6 del IC FDN305 al pin 34 del connettore floppy (cerchio rosso)
- Tagliare la traccia che va dal pin 19 del IC FDN305 al pin 12 del connettore floppy (cerchio verde)
- Tagliare la traccia che va dal pin 2 del connettore floppy al pad inferiore della piazzola R1 (cerchio blu)

- Saldare un filo dal pin 6 del IC FDN305 al pin 2 del connettore floppy (cerchi viola)
- Saldare un filo dal pin 19 del IC FDN305 al pin 10 del connettore floppy (cerchi bianchi)
- Saldare un diodo (1N4148) dal pin 34 del connettore floppy al pin 10 del connettore floppy (con il catodo verso quest'ultimo) (cerchi neri)

Come detto questo drive funziona bene sia come DF0: che come DF1: (con e senza altri drive "in catena") e non ho riscontrato difetti a parte il fatto che su Kaf Systest quando si seleziona signal anziché fermarsi a 0 comincia ad incrementare il numero degli "index pulses" praticamente all'infinito.

qui è disponibile la stessa foto con i cerchi colorati ad una maggiore risoluzione.
Magari prima o poi qualcuno ha sotto mano uno di questi NEC e può fare altre prove...

Commento modificato il 06/06/2019 alle ore 22:58:17

Pagine: -1-2-3-4-5-6-7-8-9- [10] -11-12-13-14-15-16-17-

Utenti Online
Utenti registrati: 972 dal 1 Gennaio 2006
di cui online: 1 registrati - Oge -
11 non registrati

Benvenuto all'ultimo utente registrato: RichyFreeway

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.087432146072388 secondi