Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


07 Dicembre 2017 Postato da: SukkoPera
Espansione RAM fai-da-te per A500/A500+
Volevo segnalare questo interessante thread su EAB , dove un utente ha realizzato una scheda che può funzionare da espansione 512 KB su A500 oppure 1 MB su A500+. In realtà si può avere 1 MB extra anche su A500, ma è necessario "pacioccare" con Gary.
La cosa interessante è che i file del design della scheda (sia il progetto Eagle che direttamente i Gerber) sono scaricabili liberamente e gratuitamente, per cui ci si può realizzare da soli le schede. In alternativa, si possono comprare da lui, anche se, vivendo in Australia, servirà un po' di pazienza.

Modificato il 07/12/2017 alle ore 20:20:02

Commenti: 147  Aggiungi - Pagine: 1...-4-5-6-7-8


Pagine: -1-2-3-4-5-6- [7] -8-

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
62.11.75.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.62 Safari/537.36
Commento 121
SukkoPera 18 Giugno 2018    23:18:44
Le saldature bastano da un lato. Posta una foto, perché non capisco bene cosa intendi per "raddrizzare i piedini"!

PS: Inviato connettore e jumper mancanti a majinga.

Commento modificato il 18/06/2018 alle ore 23:22:24


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

farox68

Post inviati: 77

Visulizza profilo Messaggio Personale
159.20.214.*** Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 122
farox68 18 Giugno 2018    23:39:31
Ecco le immagini...visionabili al link qui sotto.

https://imgur.com/a/dhTrXyT


Per i piedini mi riferivo alle ram (come dicevo qualche post fa..in cui tu mi hai consigliato di non raddrizzarli...anche se oramai io lo avevo già fatto).

Commento modificato il 18/06/2018 alle ore 23:54:14


Amiga 500 + A501 + KSswitcher + gotek , Monitor 1084S-P1 (da riparare)

Console Linux based:

OpenPandora classic edition , GPH GP2X F200 , GPH Caanoo, GCW-ZERO.

Android based:

JXD S7300B android 4.2



www.rbnet.it/ il blog dove ci sono i miei port per le console OpenSource

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
62.11.75.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.62 Safari/537.36
Commento 123
SukkoPera 18 Giugno 2018    23:58:01
Accidenti, ma non potevi chiedere prima di fare un lavoraccio del genere?

Come avrai capito, non era necessario, però è anche vero che non dovrebbe creare particolari problemi.

Secondo me le saldature non fanno adeguatamente contatto, sono "fredde", come si suol dire. Forse il saldatore non raggiunge una temperatura sufficiente e forse anche lo stagno non è adeguato. Andrebbero ripassate una ad una con un po' di flussante.

Oltre a questo, su che Amiga stai cercando di montarla? Un 500+? In tal caso DEVI saldare anche uno degli header 1x3 sopra al secondo chip e metterci il jumper in modo da collegare RASU2 e RAS1.

Commento modificato il 18/06/2018 alle ore 23:58:37


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

farox68

Post inviati: 77

Visulizza profilo Messaggio Personale
159.20.214.*** Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 124
farox68 19 Giugno 2018    00:04:01
Il mio 500 è rev 6 normale (non plus).

Cmq grazie riproverò a ripassare le saldature alzando la temp del saldatore (avevo messo a circa 250-300 gradi mi sembra), il flussante non ce l'ho...speravo di poter fare senza.

Amiga 500 + A501 + KSswitcher + gotek , Monitor 1084S-P1 (da riparare)

Console Linux based:

OpenPandora classic edition , GPH GP2X F200 , GPH Caanoo, GCW-ZERO.

Android based:

JXD S7300B android 4.2



www.rbnet.it/ il blog dove ci sono i miei port per le console OpenSource

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
62.11.75.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.62 Safari/537.36
Commento 125
SukkoPera 19 Giugno 2018    00:22:15
Partendo dal presupposto che stai usando stagno "tradizionale" (verifica!), ovvero CON piombo 60/40, 300°C è la temperatura minima per saldare, consiglio almeno 330°C, anche 350°C.

Su un 500 Rev.6A non ha molto senso usare 2 chip di RAM. Quale configurazione vorresti utilizzare? Il jumper per RASU2 va saldato comunque, ma messo nell'altra posizione allora.

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 2074

Visulizza profilo Messaggio Personale
151.32.183.*** Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Commento 126
Mck 19 Giugno 2018    10:42:10
Io per le saldature così piccole uso una mini stazione saldante con ministilo da 18W. Quando la punta del saldatore tocca una parte metallica (stagno, rame del pcb e pin del componente) perde istantaneamente molto calore e per questo lavoro con impostazioni di 400-450°.
Il flussante è indispensabile per poter saldare componenti sms ( il flussante ti permette di non saldare 2 pin assieme).

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

Post inviati: 402

Visulizza profilo Messaggio Personale
95.235.216.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 127
majinga 19 Giugno 2018    10:57:44
Forse era anche il caso di suggerire i socket per SOJ che sicuramente sono più facili da saldare:

https://www.ebay.com/itm/QTY-15-42-PIN-SURFACE-MOU NT-SOJ-SOCKETS-SOJ-42P-400/111206930396

Anche se non sono sicuro che ci sia spazio sufficiente per metterli, soprattutto sopra e sotto dove vanno i jumper e i condensatori.

@SukkoPera
Merci!

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
91.253.241.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 128
SukkoPera 19 Giugno 2018    11:31:54
I socket li avevo cercati ma non li avevo trovati. Certo che, visto il prezzo, li avrei comunque lasciati perdere . Vero anche che probabilmente non ci starebbero.

Però non mi sembrano affatto più facili da saldare, anzi! Alla fine con questi chip si fa in fretta, una volta che si è sviluppato un metodo. Certo, se ne devi saldare solo un paio non fai in tempo, ma avendone io saldati almeno 15... È comunque un utile esercizio.

Commento modificato il 19/06/2018 alle ore 11:32:20


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 402

Visulizza profilo Messaggio Personale
95.235.216.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Commento 129
majinga 19 Giugno 2018    11:51:33
Il vantaggio con i socket è che si ha la piena visuale dei pin in fase di saldatura.
Il problema con i SOJ è che magari si sono anche saldati bene, ma lo stagno sta solo sulla parte finale quella che tocca la piazzola e che è difficile da vedere.
Con i socket è come saldare un SOIC anche se con i pin rivolti all'interno, che è sicuramente molto più facile.

Post inviati: 402

Visulizza profilo Messaggio Personale
95.235.226.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Commento 130
majinga 18 Agosto 2018    12:21:12
Sono finalmente riuscito a montare gli altri chip di ram. E l'RTC, non sono un fan dell'RTC ma sapete com'è. Sindrome da scheda non completa.

Immagine
Immagine

Appena rimetto in sesto il Gary adapter faccio una prova.

Devo anche fare mente locale. Se non ricordo male la discussione su EAB con il Kick 1.2 si può avere al massimo 1 MB di slow. Devo rivedere come settare il gary adapter.

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
62.11.74.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36
Commento 131
SukkoPera 18 Agosto 2018    12:30:20
Sì, con la scheda completa il KS 1.2 non parte. Non ho mai provato a smanettare con i ponticelli, uso l'1.3 e basta.

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 402

Visulizza profilo Messaggio Personale
79.35.215.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Commento 132
majinga 16 Settembre 2018    19:19:32
Ok, funziona anche con il Kick 1.2, basta accontentarsi di 1 MB di slow ram invece di 1.5 MB.

Immagine
Immagine
Immagine
Immagine

L'unica cosa, uno dei due Gary adater che ho non funziona.
Non capisco, a meno che non ho fatto qualche danno quando ho cambiato il pin header. Eppure sono stato attento
Vabbè, appena posso lo controllo e vedo se trovo qualcosa che non va.

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
62.11.74.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36
Commento 133
SukkoPera 16 Settembre 2018    19:53:37
Buono a sapersi!

Per il GA, la cosa più probabile è una saldatura mal riuscita su uno dei chip 7400/7474, sono abbastanza subdoli .

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 402

Visulizza profilo Messaggio Personale
79.35.215.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Commento 134
majinga 16 Settembre 2018    20:01:42
Per il GA anche secondo me una saldatura da rifare o qualcosa del genere.
Non mi viene in mente niente che possa essere successo durante la sostituzione del pin header.
Vai a capire, in ogni caso va bene, è parte del gioco, non sempre va tutto liscio

Se a qualcuno interessa ho cercato di fare il punto con le varie configurazioni dei jumper:

Citazione

A501 mini:
512k Slow (A500):
RAM CHIPS: 1
EXRAM: closed
RASU1: RAS1
RASU2: unused
RASU3: unused
RASU4: unused
XCAS: all closed

1M Chip (A500+):
RAM CHIPS: 2
EXRAM: Open
RASU1: RAS1
RASU2: RAS0
RASU3: unused
RASU4: unused
XCAS: all closed

512k Chip + 1.0/1.5 Slow:
RAM CHIPS: 3/4
EXRAM: Closed
RASU1: RAS1
RASU2: RAS1
RASU3: RAS1
RASU4: RAS1
XCAS: all open (Gary Adapter needed)

Gary adapter:
JP1 & JP2:
1-2 for 0.5 meg chip
2-3 for 1 meg chip

JP3:
1-2 for 1.5 meg slow
2-3 for 1 meg slow

JP4:
1-2 for slowram and 1 meg chip
2-3 0.5 meg chip only

Commento modificato il 16/09/2018 alle ore 20:08:12

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Commento 135
SukkoPera 30 Ottobre 2018    14:46:58
@majinga: Che revisione della mainboard ha l'A500 con KS 1.2 su cui hai montato la scheda? Che configurazione hai ottenuto alla fine?

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 402

Visulizza profilo Messaggio Personale
79.35.215.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 136
majinga 30 Ottobre 2018    14:55:53
E' una rev. 5 con la scheda ottengo 1 MB di chip e 1 MB di slow.

EDIT:

In realtà credo che il collegamento verso JP2 non serva per questa configurazione.
Io lo avevo fatto perché avevo problemi a far funzionare il tutto, e poi il problema si è rivelato essere il GA.
E una volta tagliata la pista e saldato il cavo non c'era motivo per non tenerlo.

Commento modificato il 30/10/2018 alle ore 15:04:19

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Commento 137
SukkoPera 30 Ottobre 2018    15:06:37
Secondo me invece serve .

Grazie! Mi chiedevo a cosa si possa puntare su una Rev.3, con il vecchio Agnus da max 512 KB chip.

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 402

Visulizza profilo Messaggio Personale
79.37.210.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 138 in risposta al 137 di SukkoPera
majinga 30 Ottobre 2018    15:50:20
Citazione

Secondo me invece serve .


E' che non è chiaro. Mi ricordo di aver letto che serve per avere 1MB di chip, ma non è chiaro se parla della memoria totale o quella sulla scheda di espansione.

Di sicuro, usando la scheda di espansione con un solo chip di ram si può arrivare ad 1 MB di chip anche senza GA e senza quel ponticello verso JP2.
Quindi a che serve? Perché così può regolare gli accessi verso la slow ram?

L'alternativa è che serva solo se si deve utilizzare 1MB di chip sulla scheda di espansione, quindi con le A500+ o quelle con l'Agnus adatto.

Non so, andava fatta una prova.

Temibile Pirata

Post inviati: 685

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Commento 139
SukkoPera 30 Ottobre 2018    15:56:34
Premesso che di preciso non ho capito nemmeno io a cosa serva, la mia idea è che serve se la scheda deve apparire in parte come chip e in parte come slow RAM.

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 1507

Visulizza profilo Messaggio Personale
79.24.8.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36
Commento 140
Kyle 30 Ottobre 2018    22:23:45
Io ho una rev. 3, ma non ho il GA

Pagine: -1-2-3-4-5-6- [7] -8-

Utenti Online
Utenti registrati: 897 dal 1 Gennaio 2006
di cui online: 3 registrati - majinga - Pericle76 - zybex17 -
7 non registrati

Benvenuto all'ultimo utente registrato: enzo1414

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.072212934494019 secondi