Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


07 Dicembre 2017 Postato da: SukkoPera
Espansione RAM fai-da-te per A500/A500+
Volevo segnalare questo interessante thread su EAB , dove un utente ha realizzato una scheda che può funzionare da espansione 512 KB su A500 oppure 1 MB su A500+. In realtà si può avere 1 MB extra anche su A500, ma è necessario "pacioccare" con Gary.
La cosa interessante è che i file del design della scheda (sia il progetto Eagle che direttamente i Gerber) sono scaricabili liberamente e gratuitamente, per cui ci si può realizzare da soli le schede. In alternativa, si possono comprare da lui, anche se, vivendo in Australia, servirà un po' di pazienza.

Modificato il 07/12/2017 alle ore 20:20:02

Commenti: 152  Aggiungi - Pagine: 1...-4-5-6-7-8


Pagine: -1-2-3-4-5-6-7- [8] -

Post inviati: 768

Visulizza profilo Messaggio Personale
79.37.210.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 141 in risposta al 137 di SukkoPera
majinga 30 Ottobre 2018    22:49:09
Citazione

...
Mi chiedevo a cosa si possa puntare su una Rev.3, con il vecchio Agnus da max 512 KB chip.


Ma volevi provare con la sola slow ram? Credo che dipenda dalla versione di Agnus, ma dovrebbe esserci la possibilità di aggiungere 512 KB di slow.

Non credo che si possa fare con questa espansione, perché questa cosa non la contempla proprio.

Altrimenti rimane solo la fast, quella la puoi sempre aggiungere se hai una scheda di espansione, tanto quella se la gestisce direttamente il 68k.

Post inviati: 768

Visulizza profilo Messaggio Personale
79.37.210.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 142
majinga 30 Ottobre 2018    23:18:38
Ok, mi stavo spulciando qualcosa, qualche scheda di espansione lo fa.

Tipo questa:
https://amigastore.eu/en/277-512kb-ram-memory-expa nsion-rc512k.html

O la A512 della individual:
https://icomp.de/shop-icomp/en/shop/product/A512.h tml

In particolare in questa c'è proprio scritto nella descrizione:
Citazione

With many second-source memory expansions using megabit memory chips, the setup will tend to run unstable, because the OCS Agnus types 8370 and 8371 will not generate enough refresh-addresses for most trapdoor memory expansions that use less than 16 memory chips.

Our A512 memory expansion will run properly with all Agnus types, including OCS chips. Thanks to an additional refresh circuit, the single 4MBit memory chip will get enough refresh addresses to keep it's contents in any configuration.

...

The A512 memory expansion is compatible with all motherboard revisions from Rev.3 to Rev.8, including the A500+.


Non sono ancora sicuro che si possa fare qualcosa con questa scheda di espansione.

Commento modificato il 30/10/2018 alle ore 23:18:58

Temibile Pirata

Post inviati: 1033

Visulizza profilo Messaggio Personale
62.11.77.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.67 Safari/537.36
Commento 143
SukkoPera 31 Ottobre 2018    00:11:12
@Kyle: E in che configurazione la usi? 512K slow?

@majinga: Interessante, a questo problema del refresh non avrei mai pensato. Se però facciamo un attimo finta che non esista, quali configurazioni possiamo considerare, almeno in teoria?

- 512K slow: dovrebbe funzionare (ho una rev.3 con un'altra espansione 512 KB e funziona)
- Chip RAM extra non se ne può avere, perché è probabile che si abbia un Agnus 8371 che supporta solo 512K chip.
- Dunque al massimo possiamo puntare ad avere più slow, ma non più di 1 MB perché il KS 1.2 (che in teoria dovrebbe essere montato su tutte le rev.3, anche se una delle mie ha l'1.3, prababile sia stato sostituito però) con 1.5 MB non boota proprio, come abbiamo visto.
- Per avere più slow serve il Gary Adapter, e sulle rev.3 di solito c'è il vecchio Gary buggato, che genera interrupt spuri. Il problema si manifesta, ad esempio, in Rainbow Islands, ma potrebbe influire anche sull'espansione?

Quindi essenzialmente, se anche andasse tutto bene, possiamo avere solo mezzo o un mega di slow, concordi?

Se concordi vedo di provare queste due configurazioni nel weekend, e vediamo se i vari problemi sussistono o meno .

Commento modificato il 31/10/2018 alle ore 00:15:46


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 768

Visulizza profilo Messaggio Personale
79.37.210.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 144 in risposta al 143 di SukkoPera
majinga 31 Ottobre 2018    00:34:43
Si, concordo, ma non sono sicuro che si possano avere più di 512 KB di slow ram. In ogni caso vale la pena fare qualche prova.

Post inviati: 1677

Visulizza profilo Messaggio Personale
62.19.188.*** Mozilla/5.0 (Linux; Android 8.1.0; EML-L09) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.80 Mobile Safari/537.36
Commento 145
Kyle 31 Ottobre 2018    06:38:52
@ sukkopera

Sì, classico utilizzo con 512 kb di slow

Temibile Pirata

Post inviati: 1033

Visulizza profilo Messaggio Personale
78.14.255.*** Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1
Commento 146
SukkoPera 3 Novembre 2018    18:06:18
Dopo varie prove, posso affermare che funziona tutto come mi aspettavo:

- 512k slow OK
- 1M slow OK (Con Gary Adapter)
- 1.5M slow OK (Con Gary Adapter)

Ho fatto tutti i test su un mio rev.3 che ha KS 1.3, come già accennato. L'ultima configurazione non dovrebbe funzionare se si ha 1.2 e la seconda... Credo di sì ma sarebbe da provare.

Il Gary "vecchio" invece non sembra causare alcun problema.

Per quanto riguarda il Gary Adapter, ho usato solo i 2 fili che vanno verso l'espansione.

Immagine

Commento modificato il 03/11/2018 alle ore 19:13:43


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 768

Visulizza profilo Messaggio Personale
79.16.61.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Commento 147
majinga 3 Novembre 2018    20:10:21
Humm, quindi per la slow gli unici che contano sono il KS e Gary. Pensavo che dell'accesso alla slow se ne occupasse per lo più Agnus, e che quindi se lui aveva problemi ad andare oltre una certa quantità di memoria oltre a quella non si potesse andare.

Ottimo lavoro. Info davvero utili.

Temibile Pirata

Post inviati: 1033

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Commento 148
SukkoPera 22 Gennaio 2019    09:56:25
Di recente, nel thread su EAB, PeteAU (l'autore di questo PCB) ha confermato quel che già sospettavo : una volta che si è saldato il 74139 non si devono più chiudere i jumper XCAS (quelli che vanno tagliati per usare il Gary Adapter).

Dunque fate attenzione: a tutti quelli che hanno preso il GA ho mandato anche jumper per richiuderli, ma NON FATELO a meno di non dissaldare prima il 139, altrimenti rischiate di bruciare quest'ultimo (e probabilmente è il componente più costoso ).

Commento modificato il 22/01/2019 alle ore 12:00:32


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 768

Visulizza profilo Messaggio Personale
151.57.121.*** Mozilla/5.0 (Linux; Android 8.1.0; TA-1032) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.99 Mobile Safari/537.36
Commento 149
majinga 22 Gennaio 2019    10:35:17
Io avevo capito che andavano aperti quando si usava il ga. Mi ricordo che quando ho fatto il primo test con un solo chp di RAM e niente ga il 74139 lo avevo già saldato. I jumper li tenevo tutti chiusi, e tutto funzionava senza problemi.
È vero che la usavo pochissimo. Il floppy era da riallineare e non avevo il driveswitch.

Temibile Pirata

Post inviati: 1033

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Commento 150
SukkoPera 22 Gennaio 2019    11:14:47
Essenzialmente: quando decidi che vuoi usare il GA saldi il 139, il suo condensatore di disaccoppiamento e l'header da 2 pin a 90° e tagli i jumper XCAS.

Da quel momento non puoi più richiudere i jumper, se lo fai cortocircuiti ingressi e uscite del 139, cosa che non gli fa certo bene. Se vuoi tornare indietro devi dissaldare il 139 e chiudere i jumper XCAS.

Commento modificato il 22/01/2019 alle ore 11:15:09


A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Post inviati: 768

Visulizza profilo Messaggio Personale
151.57.121.*** Mozilla/5.0 (Linux; Android 8.1.0; TA-1032) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.99 Mobile Safari/537.36
Commento 151
majinga 22 Gennaio 2019    11:39:27
Non era molto chiaro dalla discussione su eab.
Se non vado errato quando ho avuto problemi con il ga. Una delle prove che ho fatto è stato provare senza il ga. Sicuramente ho richiuso tutti i jumper e la scheda era tutta popolata.
Fortuna che non si è bruciato niente

Temibile Pirata

Post inviati: 1033

Visulizza profilo Messaggio Personale
151.91.34.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Commento 152
SukkoPera 22 Gennaio 2019    11:50:55
Oh beh, anch'io ho fatto qualunque vakkata, e di solito è andata bene .

A500 Rev.3 1 MB, A500 1 MB, A500 Rev.6 1 MB Chip + 1.5 MB Slow, A500+ 2 MB Chip (riparato!), A600 2 MB Chip + A6095 + SD 4 GB, A600, A1200 + ACA1221EC... VIC20 e svariati C16 e C64

Pagine: -1-2-3-4-5-6-7- [8] -

Utenti Online
Utenti registrati: 937 dal 1 Gennaio 2006
di cui online: 2 registrati - gommaeacca - syncmaster -
9 non registrati

Benvenuto all'ultimo utente registrato: lroby74

Buon Compleanno a Alevarg - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.073048830032349 secondi