Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Retro-Gamers
 Lista Utenti
 Contatti
 Policy sito
Ricerca Google

Login

Nick


Password


28 Dicembre 2023 Postato da: amiwell79
MPLayer v1.5RC2 OS4
Aggiornamento di questo video player per OS4 basato sui sorgenti dell'omonimo v1.5

mplayer.lha

Modificato il 28/12/2023 alle ore 19:22:18

Commenti: 19  Aggiungi  - Leggi



Post inviati: 686

Visulizza profilo Messaggio Personale
93.65.97.*** Mozilla/5.0 (Macintosh; PowerPC AmigaOS 4.2; Odyssey Web Browser; rv:1.23 r5) AppleWebKit/538.1 (KHTML, like Gecko) OWB/1.23 r5 Safari/538.1
Commento 1
ghillo 31 Dicembre 2023    17:26:12
A me da problemi se lo uso come lettore URL in AmiTube , mi da un errore DSI con GrimpReaper sulla cache, ignoro l'errore e parte correttamente , però se poi chiudo il video e ne faccio partire un altro mi da sempre lo stesso errore e a volte tocca resettare.
Capita anche a voi avete provato, è una cosa da segnalare .

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.250.249.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 2
AfAOne 31 Dicembre 2023    17:55:19
Su OS 4.1 è una sofferenza vedere tutti i formati video più comuni, esiste un Player Commerciale che funziona bene

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


amiwell79

Post inviati: 12036

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 3
amiwell79 31 Dicembre 2023    18:06:17
prova a salvare il video e poi aprirlo successivamente con MPlayer vedi se ti da lo stesso errore

Aros - Workbench X86 - Tiny Aros Mainteiner - https://tinyaros.flazio.com

SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
80.180.50.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 4
VagaPPC 3 Gennaio 2024    00:26:12
In risposta a ghillo
ghillo

A me da problemi se lo uso come lettore URL in AmiTube , mi da un errore DSI con GrimpReaper sulla cache, ignoro l'errore e parte correttamente , però se poi chiudo il video e ne faccio partire un altro mi da sempre lo stesso errore e a volte tocca resettare.
Capita anche a voi avete provato, è una cosa da segnalare .



Hai provato a verificare il Filesystem.
A volte quando i DSI diventano tanti faccio passare NGFS check, con SFS2 si hanno motli meno problemi e maggiore stabilità, almeno fin quando non rilasceranno NGFS 2, che sembra funzionare bene e che non lo rilasceranno prima del OS 4.2.
Udarlo ha comunque i suoi vantaggi è molto più veloce degli altri.

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

Post inviati: 686

Visulizza profilo Messaggio Personale
93.65.97.*** Mozilla/5.0 (Macintosh; PowerPC AmigaOS 4.2; Odyssey Web Browser; rv:1.23 r5) AppleWebKit/538.1 (KHTML, like Gecko) OWB/1.23 r5 Safari/538.1
Commento 5
ghillo 5 Gennaio 2024    21:47:34
Io non ho ngfs , ho un vecchio XE e negli aggiornamenti non c'è presenza di quel file system, comunque uso SFS2 su un HD SATA da 1TB collegato alla 3112 su cui riesco a fare il boot di AmigaOS.
Comunque le versioni precedenti di MPlayer non danno problemi , poi strano solo se abbinato ad AmiTube.

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 6
AfAOne 5 Gennaio 2024    21:58:27
Come hai configurato AmiTube ? verifica nel suo file di config se hai impostato il comando con il corretto parametro !

Con AmiTube se scarichi il Video "formato originaro" lo vedi bene se ci clicchi sopra ?

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 7
AfAOne 6 Gennaio 2024    00:34:28
In risposta a ghillo
ghillo

A me da problemi se lo uso come lettore URL in AmiTube , mi da un errore DSI con GrimpReaper sulla cache, ignoro l'errore e parte correttamente , però se poi chiudo il video e ne faccio partire un altro mi da sempre lo stesso errore e a volte tocca resettare.
Capita anche a voi avete provato, è una cosa da segnalare .



Ho installato Mplayer e AmiTube su WinUAE OS 4.1, ed ho ricevuto il tuo stesso Errore, se la versione precedente (quale versione?) non dava questo problema potrebbe essere un errore/bug interno a MPlayer .

In pratica l'errore avviene dopo che scarica il lungo link del download e prima di iniziare a scaricare il video, se annulli il download riprende correttamente,

Se invece utilizzi scarica come MPG, il download avviene con successo, e MPlayer parte in automatico non appena il video è stato scaricato.

A mio avviso il Filesystem non c'entra nulla, altrimenti non avresti scaricato con le altre opzioni disponibili su YouTube.

Commento modificato il 06/01/2024 alle ore 00:38:02


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
95.237.210.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 8
VagaPPC 6 Gennaio 2024    10:37:41
Provo ad abbinarlo con Amitube e ti faccio sapere

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
95.237.210.*** IBrowse/3.0demo (Amiga; AmigaOS 4.1; Build 30.8 PPC)
Commento 9
VagaPPC 6 Gennaio 2024    12:11:04
Operazioni eseguite:

* Nel primo test non funzionava nulla, poi mi sono accorto che non avevo configurato Amitube sul 5k
* Dopo aver configurato ogni cosa, riscontravo ancora dei problemi, finché non mi sono accorto che avevo il FS danneggiato, ho eseguito il canonico NGFCHECK e ho riparato il filesystem.
* Sistemmato i problemi vari:
Avvio AmiTube cerco "Amiga x5000",
Clicco su "Ottieni Originale" selezionando il primo video,
Seleziono "22 - 1280 x 720 (720p)" seguito da "Usa URL Lettore"
Mi compare la finestra Grim Reapper, Guru Meditation 800000003"
Clicco su "Altro" -> "Ignora errori DSI" e funziona correttamente.

Questa cosa mi capita spesso, mi piacerebbe sapere se c'è un modo per Ignorare questi errori DSI automaticamente.

Commento modificato il 06/01/2024 alle ore 12:12:32


WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 10
AfAOne 6 Gennaio 2024    13:01:41
Praticamente lo stesso problema riscontrato da ghillo e da me, come detto credo sia un errore interno a Mplayer, su AROS x86 con Mplayer non posso usare su Amitube la funzione "Ottieni Originale" perchè Mplayer AROS anche se funziona meglio di quella OS4, tra le altre cose ha anche una bella GUI, non ha perà la funzione del download, per il resto AmiTube funziona perfettamente.

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


Post inviati: 686

Visulizza profilo Messaggio Personale
93.65.97.*** Mozilla/5.0 (Linux; Android 10; K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Mobile Safari/537.36
Commento 11
ghillo 8 Gennaio 2024    22:36:03
In risposta a amiwell79
amiwell79

prova a salvare il video e poi aprirlo successivamente con MPlayer vedi se ti da lo stesso errore


Questa cosa non l'ho provata, comunque altri video scaricati da Internet funzionano bene.

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
212.171.12.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 12
AfAOne 8 Gennaio 2024    22:56:08
Se AmiTube è stato configurato, non dovresti incontrare alcun problema perchè il Download è fatto da WGet, mentre il problema che abbiamo dissusso è dato dal Download praticato da Mplayer.

Per scaricare il video, una volta cliccato sul Tab "Ottieni Originale", e scelto il formato, poi devi cliccare sul Tab "Scarica su HD", fatto questo apparirà un Request per scegliere il percorso salvataggio.

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
79.44.132.*** Mozilla/5.0 (Macintosh; PowerPC AmigaOS 4.2; Odyssey Web Browser; rv:1.23 r5) AppleWebKit/538.1 (KHTML, like Gecko) OWB/1.23 r5 Safari/538.1
Commento 13
VagaPPC 9 Gennaio 2024    20:37:19
In risposta a AfAOne
AfAOne

Praticamente lo stesso problema riscontrato da ghillo e da me, come detto credo sia un errore interno a Mplayer, su AROS x86 con Mplayer non posso usare su Amitube la funzione "Ottieni Originale" perchè Mplayer AROS anche se funziona meglio di quella OS4, tra le altre cose ha anche una bella GUI, non ha perà la funzione del download, per il resto AmiTube funziona perfettamente.



Mi appare il Guru ma poi se clicco su Ignora DSI tutto funziona regolarmente.
Mi compare spesso quell'errore, infatti se esiste un modo per farglielo fare in automatico sarebbe una manna

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.249.95.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 14
AfAOne 9 Gennaio 2024    20:54:37
Che intenti in Atomatico, in ogni caso il file va sempre scaricato, questo accade anche sui PC, la colpa come detto potrebbe essere di MPlayer, ma anche di OS 4.1, visto che quell'errore è molto frequente.

Leggendo sui vari forum non ci sono cure ben precise a questo errore, probabilmente perchè le cause possono essere molteplici.

Hai provato su MOS se Mplayer con AmiTube funziona bene ?

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
79.44.132.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 15
VagaPPC 9 Gennaio 2024    21:23:28
In risposta a AfAOne
AfAOne

Che intenti in Atomatico, in ogni caso il file va sempre scaricato, questo accade anche sui PC, la colpa come detto potrebbe essere di MPlayer, ma anche di OS 4.1, visto che quell'errore è molto frequente.

Usando OS4 capita che alcuni programmi all'avvio mostrano il guru e vai avanti cliccando "ignora errori DSI", dopodiche il programma funziona.
Visto che non ho le competenze per il debug, e anche se le avessi il più delle volte non ho il codice sorgente.
Anziché mostrarlo, il sistema operativo potrebbe andare avanti tranquillamente e magari loggarlo.
Senza costringermmi a cliccare due o tre volte.

Come ho detto, funziona benissimo, ma dopo due o tre click, l'unico problema che ho è quello.

AfAOne
Leggendo sui vari forum non ci sono cure ben precise a questo errore, probabilmente perchè le cause possono essere molteplici.


Il OS 4.0 era letteralmente un porting di 3.9 su PPC e poco più.
4.1 invece comincia a muoversi oltre i limiti di AmigaOS, vede la ram oltre i 2G, ha la swap, aggiornamenti online come fanno gli OS moderni a differenza di windows e macos, aggiorni anche le applicazioni come netsurf, amissl, basta che l'autore lo voglia. Soltanto Linux e BSD lo fanno così. E altre chiccerie in giro.
Anche se nell'aspetto cambia poco, sotto è più evoluto. è già incredibile che ci riesce, queste cose con la memoria protetta e altre cose che ancora mancano sono la causa, e poca gente che collabora.

AfAOne

Hai provato su MOS se Mplayer con AmiTube funziona bene ?



Non ancora, ma lo farò.

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

AfAOne

Post inviati: 5652

Visulizza profilo Messaggio Personale
95.249.95.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 16
AfAOne 9 Gennaio 2024    21:39:16
Lo so che funziona se vai avanti, mi è capitato un sacco di volte, perà è antipatico, trovare le cause sugli errori OS4.1 è difficile, molti restano irrisolti come in questo caso.

Io credo che questi erroro appartengono alle libreie Linux usate da OD4.1, che non restituiscono gli errori come fanno le librerie AmigaOS a mio avviso più semplici da interpretare.

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3102

Visulizza profilo Messaggio Personale
37.160.180.*** Mozilla/5.0 (Linux; Android 10; K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/118.0.0.0 Mobile Safari/537.36
Commento 17
VagaPPC 10 Gennaio 2024    07:54:30
In risposta a AfAOne
AfAOne

Lo so che funziona se vai avanti, mi è capitato un sacco di volte, perà è antipatico, trovare le cause sugli errori OS4.1 è difficile, molti restano irrisolti come in questo caso.

Io credo che questi erroro appartengono alle libreie Linux usate da OD4.1, che non restituiscono gli errori come fanno le librerie AmigaOS a mio avviso più semplici da interpretare.



Ma va.
Lettore o meglio il return code è identico su tutti i sistemi del mondo.

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire - PC AMD Ryzen TR 64Gb RAM 3.8Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

Post inviati: 4099

Visulizza profilo Messaggio Personale
151.60.33.*** Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0
Commento 18
Mck 10 Gennaio 2024    10:50:13
Stiamo andando fuori tema se avete bisogno di aiuto esiste l'apposita sezione RICHIESTE DI AIUTO utilizzatela.
ulteriori post, fuori tema, verranno cancellati.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

amiwell79

Post inviati: 12036

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 19
amiwell79 11 Gennaio 2024    14:22:09
ma è possibile mai che sia un problema di filesystem su aros l'SFS è robbustissimo mai avuti problemi e si che non è l'ultima versione aggiornata boh!

Aros - Workbench X86 - Tiny Aros Mainteiner - https://tinyaros.flazio.com


Utenti Online
Utenti registrati: 1206 dal 1 Gennaio 2006
di cui online: 0 registrati - 
11 non registrati

Benvenuto all'ultimo utente registrato: zulu

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.057641983032227 secondi