Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Retro-Gamers
 Lista Utenti
 Contatti
 Policy sito
Ricerca Google

Login

Nick


Password


30 Dicembre 2023 Postato da: amiwell79
Netsurf v3.11
Rilasciata per OS4 nuova versione stabile di questo browser numerosi i bug corretti ancora non può effettuare il download su GitHub, una versione di testing per OS3 si può verificare

Ottimizzazioni

Versione OS4

Netsurf v11

Versione OS3

NetSurf-gcc-6637.lha

Immagine

Modificato il 01/01/2024 alle ore 22:18:03

Commenti: 58  Aggiungi - Pagine: 1-2-3


Pagine: -1- [2] -3-

SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3345

Visulizza profilo Messaggio Personale
95.237.210.*** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 21
VagaPPC 5 Gennaio 2024    14:23:41
In risposta a AfAOne
AfAOne

Entrambi i NetSurf non utilizzano le librerie poste nella Cartella AmiSSL come fa iBrowser, ma le integrano nel proprio eseguibile.


Se fanno questo c'è una ragione, è una metodica di progettazione tipica di molti prodotti.
In windows fanno sempre così, anche perché non ha un vero sistema di pacchettizzazione dei programmi.

Lo si fa per ridurre i problemi di compatibilità, oppure perché sanno di certo che il cambio di versione potrebbe portare ad alcuni malfunzionamenti, oppure perché essendo cross platform è stato fatto per avere la stessa alberatura su tutti gli OS.


WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire V4 - PC AMD Ryzen 9 7950X3D 64Gb RAM 5Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 22
amiwell79 5 Gennaio 2024    15:39:48
Integrated AmiSSL for https support. Version 4.6 recommended

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 23
AfAOne 5 Gennaio 2024    15:44:10
In risposta a VagaPPC
VagaPPC


Se fanno questo c'è una ragione, è una metodica di progettazione tipica di molti prodotti.
In windows fanno sempre così, anche perché non ha un vero sistema di pacchettizzazione dei programmi.

Lo si fa per ridurre i problemi di compatibilità, oppure perché sanno di certo che il cambio di versione potrebbe portare ad alcuni malfunzionamenti, oppure perché essendo cross platform è stato fatto per avere la stessa alberatura su tutti gli OS.



Si anche se è meglio che le librerie siano esterne, questo consente di avere sempre le librerie aggiornate per Browser, come accade per iBrowser e in parte OWB.

I 2 NetSurf della cartella AmiSSL/SSutilizzano comunque alcuni dati SSLROOT.

Commento modificato il 05/01/2024 alle ore 15:44:52


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 24
AfAOne 5 Gennaio 2024    15:47:13
In risposta a amiwell79
amiwell79

Integrated AmiSSL for https support. Version 4.6 recommended



Per una buona compatibilità con i vari Browser installati sui propri sistemi conviene tenere tutte le versioni AmiSSL nella cartella, ed è quello che faccio io, nessuna possibilità di conflitto perchè ogni versione di AmiSSL ha dei nomi differenti.

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 25
amiwell79 5 Gennaio 2024    16:25:41
In risposta a amiwell79
amiwell79

Integrated AmiSSL for https support. Version 4.6 recommended



questo l'ho letto nel blog di arti

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 26
AfAOne 5 Gennaio 2024    16:37:19
Si perchè in quel periodo era quella la versione AmiSSL in uso, dopodichè anche se installi le nuove versioni, NetSurf le ignorerà.

Ecco perchè io ho tutte le versioni di AmiSSL installate, in questo caso tutti, ovvero AWeb, I Browser, i 2 NetSurf e tutte le Altre App che ne fanno uso troveranno la versione che gli serve.

Commento modificato il 05/01/2024 alle ore 16:59:22


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 27
amiwell79 5 Gennaio 2024    17:46:41
aweb è stato ricompilato con il nuovo SDK di AmiSSL non ha bsogno di librerie aggiuntive e funziona su tutti i siti amighisti come IBrowse

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3345

Visulizza profilo Messaggio Personale
95.237.210.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 28
VagaPPC 5 Gennaio 2024    18:20:42
In risposta a AfAOne
AfAOne

Si perchè in quel periodo era quella la versione AmiSSL in uso, dopodichè anche se installi le nuove versioni, NetSurf le ignorerà.

Ecco perchè io ho tutte le versioni di AmiSSL installate, in questo caso tutti, ovvero AWeb, I Browser, i 2 NetSurf e tutte le Altre App che ne fanno uso troveranno la versione che gli serve.



In questo caso è più conveniente una gestione con un proxy esterno.
Perché se la libreria è troppo datata per il sito, il browser non visualizzerebbe la pagina.
Così facendo demando al proxy la gestione dei certificati e riesco a navigare anche con Vojager che era il mio preferito anche se usavo sempre ibrowse per la stabilità.

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire V4 - PC AMD Ryzen 9 7950X3D 64Gb RAM 5Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 29
AfAOne 5 Gennaio 2024    18:39:29
In risposta a amiwell79
amiwell79

aweb è stato ricompilato con il nuovo SDK di AmiSSL non ha bsogno di librerie aggiuntive e funziona su tutti i siti amighisti come IBrowse



Sei sicuro, con AWEB se non hai la libreria AmiSSL or MiamSSL, o una Assegnazione a AmiSSL non vai su nessun sito HTTPS, vedi screenshot

Stessa cosa per iBrowse

Immagine




@VagaPPC

Si buona idea, ma credo sia una operazione complicata per molti, quanta gente ha un Secondo Computer sempre acceso che gli fa da Server Proxy, tanto vale usare solo quel secondo PC per navigare meglio e più veloce con un Browser moderno.

In Ogni caso anche se utilizzi un Proxy nel sistema comunque devono essere installate le librerie necessarie.

Commento modificato il 05/01/2024 alle ore 19:08:24


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3345

Visulizza profilo Messaggio Personale
95.237.210.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
Commento 30
VagaPPC 5 Gennaio 2024    20:14:44
In risposta a AfAOne
AfAOne

In risposta a amiwell79
amiwell79

aweb è stato ricompilato con il nuovo SDK di AmiSSL non ha bsogno di librerie aggiuntive e funziona su tutti i siti amighisti come IBrowse



Sei sicuro, con AWEB se non hai la libreria AmiSSL or MiamSSL, o una Assegnazione a AmiSSL non vai su nessun sito HTTPS, vedi screenshot

Stessa cosa per iBrowse

Immagine




@VagaPPC

Si buona idea, ma credo sia una operazione complicata per molti, quanta gente ha un Secondo Computer sempre acceso che gli fa da Server Proxy, tanto vale usare solo quel secondo PC per navigare meglio e più veloce con un Browser moderno.


Si può usare anche una raspberry, in molti nas la si può trovare nelle applicazioni, ci sono soluzioni per tutti i gusti.
Di solito le applica chi già utilizza questi apparecchi.

AfAOne
In Ogni caso anche se utilizzi un Proxy nel sistema comunque devono essere installate le librerie necessarie.

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire V4 - PC AMD Ryzen 9 7950X3D 64Gb RAM 5Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 31
amiwell79 5 Gennaio 2024    20:48:19
sono usciti solo gli eseguibili ricompilati

eseguibili ricompilati e da sostituire con la versione sotto dopo l'installazione

http://aminet.net/comm/www/aweb_3_5_091.lha

versione da installare

https://aminet.net/package/comm/www/aweb3.5.09_68k _20070721

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 32
AfAOne 5 Gennaio 2024    21:53:59
Il pacchetto Completo di AWEB da te linkato funziona perchè dentro c'è AmiSSL da installare, Libreria "amisslmaster.library" e "Certs" (certificati), se non installi AmiSSL, AWEB come altri Browser Amiga non potrà andare su nessun sito HTTPS

non è corretta la tua affermazione queto pacchetto è l'ultimo disponibile rilasciato e non devi installare nulla riguardo amissl io l'ho provato con successo






Commento modificato il 06/01/2024 alle ore 12:38:36


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 33
AfAOne 6 Gennaio 2024    12:05:59
Probabilmente lo sviluppatore di NetSurf (port OS4) ha letto questo post

Uscita questa mattina su Aminet una nuova versione 3.11 contrassegnata come BETA, questa va sui siti HTTPS, ha i colori sfasati e in uscita dal Browser congela il sistema operativo, almeno questo capita su sistemi RTG.

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


SysAdmin Unix/Linux - fiero o folle possessore di un AmigaOne

Post inviati: 3345

Visulizza profilo Messaggio Personale
95.237.210.*** IBrowse/3.0demo (Amiga; AmigaOS 4.1; Build 30.8 PPC)
Commento 34
VagaPPC 6 Gennaio 2024    12:13:28
I colori sfasati li avevo anche prima

WorkStation: Amiga x5000 AOS4.1 - MorphOS MiniMac - Vampire V4 - PC AMD Ryzen 9 7950X3D 64Gb RAM 5Ghz

Old System Amiga 500,1200, A4000/60 PowerPPC, CybervisionPPC, SUN Ultra5, PowerMAC G4 450Mhz 1Gb

amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 35
amiwell79 6 Gennaio 2024    12:41:49
carlo il problema è che tu non sei a conoscenza di quest'ultimo upgrade

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 36
AfAOne 6 Gennaio 2024    12:54:48
Salvo io testo da anni ogni versione che esce anche quelle non pubbliche, e su diversi OS, i colori nella versione 3.10 andavano bene ! posso dimostrarlo !

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 37
amiwell79 6 Gennaio 2024    12:59:20
io sto parlando di aweb quest'ultima versione che contiene l'eseguibile da sovrascrivere al vecchio pacchetto non ha bisogno di amissl, l'ho testata

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 38
AfAOne 6 Gennaio 2024    13:41:14
Salvo conosco molto bene AWEB usato molti anni sul mio A4000, come ho mostrato nello screenshot AWEB anche i nuovi eseguibili non possono andare sui siti HTTPS se non è installata la Libreria "amisslmaster.library" ?

Prova ad eliminare questa libreria da AmiSSL o da SYS:Libs e avrai l'errore mostrato nella finestra !

Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


amiwell79

Post inviati: 12548

Visulizza profilo Messaggio Personale
95.250.37.*** Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36
Commento 39
amiwell79 6 Gennaio 2024    15:21:31
io non ti sto parlando di molti anni fa ti sto parlando del presente

Curatore della Distribuzione Tiny Aros https://www.tinyaros.it




AfAOne

Post inviati: 6086

Visulizza profilo Messaggio Personale
95.238.254.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
Commento 40
AfAOne 6 Gennaio 2024    15:26:18
Salvo riguardo il bisogno della "amisslmaster.library" sto parlando anche dell'ultima versione di AWEB ! provalo e vedrai quello che ho affermato !

Commento modificato il 06/01/2024 alle ore 15:27:23


Immagine AROS One x86/68k
- AfA One - AfA One PPC - Amilator AfA One - Amithlon AfA One - WinUAE OS 4.1


Pagine: -1- [2] -3-

Utenti Online
Utenti registrati: 1220 dal 1 Gennaio 2006
di cui online: 0 registrati - 
156 non registrati

Benvenuto all'ultimo utente registrato: stell

Buon Compleanno a vitant66 - strato55 - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.020565032958984 secondi