Menù principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Retro-Gamers
 Lista Utenti
 Contatti
 Policy sito
Ricerca Google

Login

Nick


Password


02 Maggio 2021 Postato da: AMG_Novice_Usr
disco rigido esterno via USB con dentro vari OS … problemi
Vi sottopongo una questione che sto affrontando in questi giorni.
Ho un disco rigido esterno della WD, da 1TB, collegabile al PC/Notebook via USB 3.0.
L’intenzione è quella di preparare questo HDD con una serie di partizioni, alcune di queste per data-storaging vario (backup per tempo libero, lavoro ecc …), altre partizioni invece le vorrei bootable, e dentro a quest’ultime ci voglio mettere alcuni OS, per lo più Windows e Lubuntu/GNU-Linux, poi magari potrei provare anche OS un po' più “amigosi”, Aros in primis …
La tabella delle partizioni è, di default, GUID Partition Table (GPT), ovvero lo standard de-facto da Win8 compreso in poi, e qui vi linko un articolino sintetico, ma abbastanza esaustivo, circa le differenze fra MBR e GPT (da inesperto, l’ho trovato istruttivo).

link

Ad ogni modo io ho trovato come tabella delle partizioni e bootloader limitrofo il formato GPT e non voglio (non avrebbe senso) effettuare un downgrade da GPT a MBR (qualora avessi trovato MBR, avrei fatto l’upgrade MBR -> GPT, dato che qualunque SW di partitions-management mette a disposizione una utility che consente di creare/rigenerare un GPT partendo da un MBR).
Qualora avessi in animo di avviare un OS vetusto, ad esempio WinXP, potrei andare nelle impostazioni dell’UEFI del mio PC e selezionare l’opzione “Legacy ON”, quindi attivazione dell’avvio in modalità “legacy”, ossia abilitazione del CSM (Modulo di Supporto alla Compatibilità): tale opzione consente al FW “UEFI” (correggetemi se sbaglio) di lavorare in modalità “BIOS”, quindi tramite il famoso interrupt di sistema IRQ 0x19 di cercare ed eseguire (dopo averlo copiato in RAM, all’indirizzo storico 0x00007C00) il bootloader contenuto nei primi 446 bytes dell’MBR, dove l’MBR (mi sembra di aver capito dal link di cui sopra) è mantenuto come primo LBA, primo blocco da 512 bytes (LBA-0) del ben più grande GPT, questo per consentire appunto ad un sistema x86 “vecchio”, quindi con un BIOS anziché un UEFI come FW di avvio, di lanciare un OS vetusto come Win2000, ME, XP ecc … da un HDD “moderno”, ovvero identificato/mappato dal GPT anziché dal semplice MBR.

Corretto link errato. Mck.

Modificato il 02/05/2021 alle ore 14:26:10

Commenti: 7  Aggiungi  - Leggi

Indice: Forum / Windows


utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 1
AMG_Novice_Usr 2 Maggio 2021    12:03:06
Ho pertanto preparato una partizione primaria da 512GB (metà dell’HDD) formattata in NTFS (ho preferito NTFS al FAT32 perché voglio prevedere delle cartelle con speciali diritti di accesso, user-sensitive … come sappiamo FAT32 non fornisce la possibilità di protezioni semplici in base all’utente o al gruppo, cosa invece normale per NTFS), e questa partizione la riservo appunto per i miei data-backups da ambienti sia Windows che GNU/Linux … fin qui, tutto liscio.
Adesso mi accingo a fare qualcosa che non avevo mai fatto prima (immagino che per uno smanettone qualunque, quanto sto per presentare costituisca pane quotidiano … io sto imparando, o meglio, ci sto provando, solo ora).
Ho realizzato diverse partizioni (una decina), ciascuna da circa 50GB, o comunque poche decine di GB, ciascuna delle quali dovrebbe ospitare una particolare installazione di OS che vorrei provare, installazioni eseguibili a partire da chiavette USB Live oppure da immagini .ISO che avevo di già, quindi in una di queste partizioni vorrei installare Lubuntu 20.04 LTS, in un’altra vorrei installare Win7-Pro, in un'altra WinXP, ecc …

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541

utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 2
AMG_Novice_Usr 2 Maggio 2021    12:03:46
L’installazione di Lubuntu 20.04 LTS è andata subito bene.
Avevo già una chiavetta USB con dentro l’immagine Live di Lubuntu 20.04 LTS.
Ho pertanto avviato il PC con la chiavetta USB, ho bootato da questa chiavetta, ho quindi lanciato l’utility di installazione di Lubuntu, la quale mi ha consentito di plasmare 4 partizioni, che sono:
-una partizione di circa 20GB: file-system ext4 – punto di montaggio: /home
-una partizione di circa 15GB: file-system swap (credo che sia una specie di RAW) – punto di montaggio: sarebbe la swap-area di Lubuntu, l’equivalente del file “pagefile.sys” di Windows (che si trova in C: ) dove lo schedulatore a lungo termine salva le pagine dei processi, pagine che non vengono indirizzate spesso e/o che è da tanto tempo che non vengono indirizzate (Linux pare che richieda una partizione separata particolare, con un file-system particolare, da adibire a disk-storage per le pagine poco usate dei processi ready … qui si potrebbe aprire un topic dedicato!)
Avendo una RAM da 8GB, 16GB di swap-area vanno benone! Almeno, le buone pratiche di realizzazione della memoria virtuale (RAM fisica + swap-area) sono così soddisfatte.
-una partizione di circa 15GB: file-system FAT32 – punto di montaggio: /boot/efi – è la famosa partizione con flag ESP abilitato, ovvero partizione ESP, che sta per EFI Separated Partition, ovvero la partizione che contiene la tabella delle partizioni, in due copie, una copia chiamata “Primary GPT” ed una seconda copia di sicurezza/ridondanza (controllo CRC32) chiamata “Secondary GPT”, più il bootloader.
-una partizione di circa 67GB: file-system ext4 – punto di montaggio: / (la folder “root”)

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541

utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 3
AMG_Novice_Usr 2 Maggio 2021    12:04:17
Se appena accendo il PC entro nell’UEFI-boot-options, e seleziono la voce “OS-boot ubuntu (UEFI)”, effettivamente viene avviato Lubuntu 20.04 LTS e tutto funziona come da manuale.
Su questo punto scatterebbe una prima domandina:
come mai, nonostante io abbia selezionato come boot-priority, la voce “USB-HDDs &pens” con maggiore priorità (la massima) nell’elenco, mentre invece la voce “SATA-inner HDD” con la priorità minore, all’avvio del PC, con HDD esterno collegato al PC via USB, il FW “UEFI”, sia in modalità vecchia “BIOS” (CSM “ON”) che in modalità normale/moderna “UEFI” (CSM “OFF”), non riesce ad avviare automaticamente Lubuntu installato sull’HDD-USB esterno, si avvia invece Win10 su SATA-HDD interno? Se voglio avviare Lubuntu, devo entrare nell’UEFI all’accensione del PC ed avviare manualmente il disco USB esterno con dentro Lubuntu … perché avviene questo?
Se richiesto/utile per voi, posso linkare foto delle schermate UEFI in questione …

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541

utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 4
AMG_Novice_Usr 2 Maggio 2021    12:04:53
Ad ogni modo, riesco a lanciare Lubuntu … fin qui, tutto ok.
Quello che ancora non riesco a fare è di installare, su altre partizioni sull’HDD esterno USB, degli altri OS come ad esempio WinXP-64bit-english oppure Win7-Pro.
Di questi OSs ho le rispettive immagini .ISO, che monto su lettori ottici virtualizzati con Daemon Tool Lite versione free (questo SW gira sul mio PC fisico, su cui ho Win10 – Home edition).
Pertanto, dopo aver montato su lettore ottico virtuale la voluta .ISO, entro con esplora-risorse nel CD montato, lancio setup.exe, appare quindi la schermata di WinXP-64 piuttosto che di Win7.
Nel caso di WinXP-64, appare la schermata iniziale dell’installer, con la voce “Install XP” ingrigita, disabilitata, mentre io mi sarei aspettato che tale voce fosse cliccabile/eseguibile … invece no.
Le altre voci del menu invece sono abilitate, ma a me non interessato in questa fase …
Nel caso di Win7, la voce “Install” è abilitata.
Procedo quindi lungo tale wizard, durante la quale mi viene chiesto se voglio installare Win7 con oppure senza il supporto di internet, ed io ho provato entrambe le strade … stesso risultato (a cui sto per arrivare).
Clicco su “i agree” del contratto, e accedo quindi alla selezione della partizione su disco 0 oppure su disco 1 nella quale voglio installare Win7-Pro.
Il disco 0 è il disco interno via SATA, quello di sistema di default, del PC insomma, su cui gira Win10, e che non voglio toccare: non voglio aggiungere partizioni, non voglio neppure “sfiorare” la partizione di sistema EFI (o meglio detto, la partizione EFI-Separated-Partition, la partizione ESP in FAT32, che contiene la GPT). Questa ESP non la voglio neppure “grubbare”, cioè non voglio metterci il bootloader grub di Lubuntu, e infatti la partizione EFI (ESP) FAT32 di sistema, per far avviare Lubuntu, l’ho messa nel disco 1, cioè nel disco esterno USB, dato che il disco 0 SATA interno non lo vorrei toccare, deve restare così com’è, per ragioni di sicurezza.
Dicevo, adesso seleziono una partizione (come detto prima, ne ho diverse) sul disco 1 esterno via USB, sulla quale voglio installare Win7-Pro, di cui sto eseguendo la wizard dell’installer … ebbene, qui nasce il bus-illis: appena seleziono su questa partizione, ed in generale su qualunque partizione del disco 1 USB, l’installer di Win7 mi dice che “Windows non può essere installato su quella partizione”.
Motivo:
l’installer dentro la .ISO di Win7 non ha il driver dell’HUB USB 3.0 (se richiesto/utile, posso mandare screeshots, così da farvi vedere il messaggio nella sua esattezza), insomma manca il driver che consentirebbe all’installer di Win7 che sto eseguendo di vedere correttamente il disco esterno via USB.
Altra possibilità paventata dall’installer, è che quel particolare disco non è utilizzabile in questo modo (tendo più a credere al primo punto … voi che ne pensate?).
Altra possibilità, è che il FW UEFI non sia impostato in modalità di compatibilità, stile BIOS/x86.
Quest’ultima possibilità l’ho risolta da quando ho selezionato in UEFI l’opzione “legacy ON”, quindi da quando ho abilitato il CSM.
E infatti la terza possibilità non me l’ha più data, quindi rimangono le prime due … io credo che sia la prima!

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541

utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 5
AMG_Novice_Usr 2 Maggio 2021    12:05:17
Ho quindi provato a caricare dall’installer di Win7-Pro il driver “USBSTOR.SYS”, che si trova in C: WindowsSystem32drivers.
Il selettore dell’installer mi consente di navigare lungo suddetto path e di arrivare fino alla cartella “drivers”, ma a questo punto non mi consente di selezionare selettivamente il file “USBSTOR.SYS”, quindi io seleziono tutta la cartella “drivers” … il risultato è questo:
“windows non può caricare la cartella poiché questa non contiene drivers firmati/riconoscibili dall’installer di Windows”.
Al solito, se utile posso postare lo screeshot con il messaggio esatto, ma la sostanza è quella che vi ho detto qui.
Ho provato anche a lanciare setup.exe da CD-ROM fisico, poiché lo possiedo, CD da cui ho ricavato il file .ISO, così da fugare i dubbi circa il corretto funzionamento del montaggio virtuale delle .ISO tramite Daemon Tool Lite: stesso problema di prima, pertanto Daemon non era il problema, lo fa anche da CD fisico.
Come posso risolvere la cosa? Ovvero installare un Windows (XP, 7, ecc …) su una partizione nell’HDD esterno via USB?
Cosa sto sbagliando?
Grazie!

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541

Post inviati: 3554

Visulizza profilo Messaggio Personale
62.10.186.*** Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0
Commento 6
Mck 2 Maggio 2021    14:31:36
Il grub per avviare linux dove lo hai installato.

I MIEI AMIGA

4000T OS 3.9 PPC/68060 + CyberVisio 64/3D + HD 20g + DVD - 4000D in Tower OS 3.9 PPC/68060 Ram 128M + ram scheda 2+16M + zip 100M + Ide HD 40G + usb Deneb + V-Lab + Toccata + Mediator con: Woodoo 3 + Scheda rete + Impact Vision 24 - 4000D OS 3.9 68060 ram 32m + ram scheda 2+16M + HD 20g + zip 100 ide + DVD + V-lab + Seriale veloce + Scheda video EGS- 3000T OS 3.9 PPC/68060 128M + HD scsi 10G + Usb Deneb + CD sCSI + mediator con: scheda rete + controllo SCSI Adaptec + scheda audio + Voodoo 5 - 3000 OS 3.1 68040 + emulatore pc 286 - 2000 processore 68030 + genlock + espansione ram + emulatore pc 8080 - 1200 Tower OS 3.9 PPC/68060 + HD 20G + Mediator con: scheda rete - 1200 OS 3.1 68060 + HD 20G + Scheda rete pcmcia - 1000 espansione Ram 4M - 600 con espansione ram + HD5G - 500 Plus con espansione ram - 500 con espansione ram - CDTV - CD32

CLONI AMIGA

Sam440ep-Flex OS 4.1 - EFIKA MorphOS 2.6

utente amiga quadratico medio

Post inviati: 518

Visulizza profilo Messaggio Personale
95.238.207.*** Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
Commento 7
AMG_Novice_Usr 2 Maggio 2021    19:25:08
Citazione

Il grub per avviare linux dove lo hai installato?


Ho creato la partizione di sistema "EFI", o meglio detto, la partizione "ESP" (E.S.P. - EFI Separated Partition), formattata con filesystem FAT32 e punto di montaggio nel path "/boot/efi", nell'HDD esterno collegato al PC via USB.
Essendo il grub il bootloader di primo livello (correggimi se sbaglio) che si trova nella partizione EFI, possiamo dire quindi che il grub si trova nell'HDD esterno suddetto.
Mi sembra di aver capito (dimmi se erro) che nella partizione di sistema EFI abbiamo come primo settore (LBA-0) l'MBR nudo e crudo, e questo serve per la retro-compatibilità di un disco GPT con i sistemi x86 montanti un BIOS tradizionale, che si aspetta di trovare l'MBR come primo settore su un hard-disk (giusto?), poi a partire dal secondo settore in poi (LBA-1,2,...) abbiamo la prima copia della tabella delle partizioni (primary GPT), poi abbiamo il bootloader, in questo caso il grub (la teoria dice, se ho capito bene, che ci possono essere più bootloaders, ciascuno per un OS particolare e/o per un file-system particolare, quindi mi aspetto che lì ci vada il bootloader per Windows, quello per GNU/Linux, ovvero il grub, ecc ...), poi la seconda copia della tabella delle partizioni (secondary GPT).
Quando ho installato Lubuntu da pennetta USB-Live, avevo 2 possibilità:
opzione 1:
mettere tutto Lubuntu dentro una partizione del disco 1, cioè il disco montato in "/devs/sdb" (es: "/devs/sdb7"), ossia l'HDD-USB esterno.
Inizialmente ho scelto questa prima opzione "automatica", non manuale, ma sono subito tornato indietro poichè tale opzione imponeva la creazione della partizione di sistema EFI (ESP) dentro "/devs/sda1", ovvero dentro la prima partizione del disco 0, cioè il disco interno SATA.
Questo avrebbe "sporcato" (modificato, grubbato, linuxato) il bootloader-code dentro la partizione di sistema EFI (FAT32) con il grub appunto ... corretto?
Quindi all'accensione del PC, comparirebbe la schermata del grub che mi chiede quale partizione bootable io voglio lanciare, e allo scadere del timeout (qualora io non selezioni nulla) verrebbe avviata la partizione "/devs/sdb7", quindi sul disco esterno USB, con dentro la root dell'installazione di Lubuntu (di default grub avvia Lubuntu).
Io per sicurezza ho preferito non alterare il bootloader-code dentro la partizione di sistema EFI nel disco 0 interno (SATA), infatti voglio lasciare la EFI del disco SATA così com'è, non grubbare la partizione EFI.
Pertanto ho optato per:
opzione 2:
creare a mano le partizioni root, home (queste 2 in ext4), partizione swap in file-system swap e partizione EFI in FAT32, quest'ultima dentro l'HDD-esterno USB, così ho tutto nel disco esterno, quello interno SATA non viene sfiorato minimamente da questi esperimenti.

A500-Plus + A501 + switch meccanico per selezione Double-kickstart 1.3 v. 34.5 / 3.1 v. 40.63 /// A600, Rev. MB. 1.5, espansione in trap-door 1MB chip-ram, Kick-Cloanto 45.66, HDD interno a tracce da 2GB modello MK2104MAV by Toshiba su porta IDE: partizione DH1 con WB2.1 (default) + partizione DH2 con WB3.1 /// A500, Kick 1.3 v. 34.5, scheda espansione in trap-door da 512KB /// A600, espansione da 4MB-fast-ram innestata con zoccolo direttamente su 68K, Kick 2.05 v. 37.300, espansione di chip-ram in trap-door da 1MB, CF da 4GB su adattatore interno CF/IDE: partizione DH0 con CWB GAAE, partizione DH1 con WB2.1, partizione DH2 con WB1.3 /// A500, Rev. MB 6A, Kick 1.3 v. 34.5, A520-TV-RF-Modulator /// A500, PWR-LED ROSSO. Kick 1.2 v. 33.180 /// A500-Plus, PWR-LED ROSSO, Kick 2.04 v. 37.175, Driver DF1 esterno Savage DMF 322, A590 alimentato da alimentatore di CD32, con dentro espansione da 2MB di fast-ram + HDD SCSI Seagate ST32151N da 2GB - DH0 con WB 2.04 e DH1 con WB 1.2 /// A1200, 68EC020, Kick 3.0 v. 39.106, HDD a tracce Hitachi 40GB interno su porta IDE con installato CWB, espansione A1208 in trap-door da 8MB-fast-ram, PLipBox su porta parallela per collegamento via Ethernet a Internet /// Commodore 64 Assy NO. 250425 + floppy drive 5’’ 1/4 modello 1541


Indice: Forum / Windows

Utenti Online
Utenti registrati: 1001 dal 1 Gennaio 2006
di cui online: 7 registrati - VagaPPC - cpiace64 - Loom4ever - marco16779 - GabrieleNick - DrProcton - zybex17 -
24 non registrati

Benvenuto all'ultimo utente registrato: wifi75

Buon Compleanno a funkytarro87 - 

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito è dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.063573122024536 secondi